dev-python/aplpy: remove last-rited pkg
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 17:26:09 +0000 (20:26 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 17:26:09 +0000 (20:26 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-python/aplpy/Manifest [deleted file]
dev-python/aplpy/aplpy-1.0.ebuild [deleted file]
dev-python/aplpy/aplpy-1.1.1.ebuild [deleted file]
dev-python/aplpy/files/aplpy-1.0-fix-dependencies.patch [deleted file]
dev-python/aplpy/files/aplpy-1.0-mark-known-failures.patch [deleted file]
dev-python/aplpy/metadata.xml [deleted file]

diff --git a/dev-python/aplpy/Manifest b/dev-python/aplpy/Manifest
deleted file mode 100644 (file)
index 094a79b..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST APLpy-1.0.tar.gz 1169280 BLAKE2B 10c7133c5708412741e25b85f3286d28ab36c5ab69fa65dcbb8b1607c171f1fc5c7b341fea8255176a90d97e18c7a5071d9f3e7848558ee66f7f48de0cf9ea09 SHA512 658b626c2a94c73cc8ba45fde86409659555ed3ec065d07313f08b67c0bcdc596c8dc94562c924de2f3f32d6884051e6756e22384d9594c4538578b482fa7590
-DIST APLpy-1.1.1.tar.gz 938943 BLAKE2B 1b5ca8f1312a0bccea46a3d7bf3dd8cc7a003083cc321147d24c650abe6bc77c3b2398db64687d3603a1077f3253a1cccf37efe874148c681393563991f96b43 SHA512 accc355fb56145db33a931b77b9d5b56e5e0f5a486a3a8d776b0645991883df4b78fae58cfe87c1575dad7f02baa5c68c95427c1de18c2435abd13c4a85eee93
diff --git a/dev-python/aplpy/aplpy-1.0.ebuild b/dev-python/aplpy/aplpy-1.0.ebuild
deleted file mode 100644 (file)
index 1b77d9a..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1 virtualx xdg-utils
-
-MYPN=APLpy
-MYP=${MYPN}-${PV}
-
-DESCRIPTION="Astronomical Plotting Library in Python"
-HOMEPAGE="https://aplpy.github.com/"
-SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
-       dev-python/astropy[${PYTHON_USEDEP}]
-       dev-python/numpy[${PYTHON_USEDEP}]
-       dev-python/matplotlib[${PYTHON_USEDEP}]
-       dev-python/pyavm[${PYTHON_USEDEP}]
-       dev-python/pillow[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/astropy-helpers[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MYP}"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-1.0-mark-known-failures.patch"
-       "${FILESDIR}/${PN}-1.0-fix-dependencies.patch"
-)
-
-python_prepare_all() {
-       sed -i -e '/auto_use/s/True/False/' setup.cfg || die
-       xdg_environment_reset
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       distutils-r1_python_compile --use-system-libraries
-}
-
-python_test() {
-       distutils_install_for_testing
-       cd "${TEST_DIR}" || die
-       virtx "${EPYTHON}" -c "import aplpy, sys;r = aplpy.test();sys.exit(r)"
-}
diff --git a/dev-python/aplpy/aplpy-1.1.1.ebuild b/dev-python/aplpy/aplpy-1.1.1.ebuild
deleted file mode 100644 (file)
index 75229e2..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1 virtualx xdg-utils
-
-MYPN=APLpy
-MYP=${MYPN}-${PV}
-
-DESCRIPTION="Astronomical Plotting Library in Python"
-HOMEPAGE="https://aplpy.github.com/"
-SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
-       dev-python/astropy[${PYTHON_USEDEP}]
-       dev-python/numpy[${PYTHON_USEDEP}]
-       dev-python/matplotlib[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/astropy-helpers[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest-mpl[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MYP}"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-1.0-fix-dependencies.patch"
-)
-
-python_prepare_all() {
-       sed -i -e '/auto_use/s/True/False/' setup.cfg || die
-       xdg_environment_reset
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       distutils-r1_python_compile --use-system-libraries
-}
-
-python_test() {
-       distutils_install_for_testing
-       cd "${TEST_DIR}" || die
-       echo "backend: Agg" > matplotlibrc
-       virtx "${EPYTHON}" -c "import aplpy, sys;r = aplpy.test();sys.exit(r)"
-}
-
-pkg_postinst() {
-       optfeature "Interact with Montage"                              dev-python/montage-wrapper
-       optfeature "Read DS9 regions files"                             dev-python/pyregion
-       optfeature "Extend image i/o formats"                   dev-python/pillow
-       optfeature "Astronomy Visualization Metadata tagging" dev-python/pyavm
-}
diff --git a/dev-python/aplpy/files/aplpy-1.0-fix-dependencies.patch b/dev-python/aplpy/files/aplpy-1.0-fix-dependencies.patch
deleted file mode 100644 (file)
index b5708c8..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-Author: Ole Streicher <olebole@debian.org>
-Description: Change requires to install_requires
---- a/setup.py
-+++ b/setup.py
-@@ -94,8 +94,7 @@
-       version=VERSION,
-       description=DESCRIPTION,
-       scripts=scripts,
--      requires=['astropy', 'numpy', 'matplotlib'],
--      install_requires=['astropy'],
-+      install_requires=['astropy', 'numpy', 'matplotlib'],
-       provides=[PACKAGENAME],
-       author=AUTHOR,
-       author_email=AUTHOR_EMAIL,
diff --git a/dev-python/aplpy/files/aplpy-1.0-mark-known-failures.patch b/dev-python/aplpy/files/aplpy-1.0-mark-known-failures.patch
deleted file mode 100644 (file)
index cf1aa92..0000000
+++ /dev/null
@@ -1,121 +0,0 @@
-Author: Ole Streicher <olebole@debian.org>
-Description: Mark tests that are known to fail with matplotlib-1.5
---- a/aplpy/tests/test_images.py
-+++ b/aplpy/tests/test_images.py
-@@ -61,6 +61,8 @@
- class TestBasic(BaseImageTests):
-+# see https://github.com/aplpy/aplpy/issues/278
-+    @pytest.mark.xfail()
-     # Test for showing grayscale
-     def test_basic_image(self, generate):
-         f = FITSFigure(self.filename_2)
-@@ -68,6 +70,8 @@
-         self.generate_or_test(generate, f, 'basic_image.png')
-         f.close()
-+# see https://github.com/aplpy/aplpy/issues/278
-+    @pytest.mark.xfail()
-     def test_ticks_labels_options(self, generate):
-         f = FITSFigure(self.filename_2)
-         f.ticks.set_color('black')
-@@ -84,6 +88,8 @@
-         self.generate_or_test(generate, f, 'tick_labels_options.png')
-         f.close()
-+# see https://github.com/aplpy/aplpy/issues/278
-+    @pytest.mark.xfail()
-     # Test for showing colorscale
-     def test_show_colorbar_scalebar_beam(self, generate):
-         f = FITSFigure(self.filename_1)
-@@ -96,6 +102,8 @@
-         self.generate_or_test(generate, f, 'colorbar_scalebar_beam.png')
-         f.close()
-+# see https://github.com/aplpy/aplpy/issues/278
-+    @pytest.mark.xfail()
-     # Test for overlaying shapes
-     def test_overlay_shapes(self, generate):
-         f = FITSFigure(self.filename_1)
-@@ -112,6 +120,8 @@
-         self.generate_or_test(generate, f, 'overlay_shapes.png')
-         f.close()
-+# see https://github.com/aplpy/aplpy/issues/278
-+    @pytest.mark.xfail()
-     # Test for grid
-     def test_grid(self, generate):
-         f = FITSFigure(self.filename_1)
-@@ -125,6 +135,8 @@
-         self.generate_or_test(generate, f, 'grid.png')
-         f.close()
-+# see https://github.com/aplpy/aplpy/issues/278
-+    @pytest.mark.xfail()
-     # Test recenter
-     def test_recenter(self, generate):
-         f = FITSFigure(self.filename_2)
-@@ -135,6 +147,8 @@
-         self.generate_or_test(generate, f, 'recenter.png')
-         f.close()
-+# see https://github.com/aplpy/aplpy/issues/278
-+    @pytest.mark.xfail()
-     # Test overlaying contours
-     def test_contours(self, generate):
-         data = np.arange(256).reshape((16, 16))
-@@ -144,6 +158,8 @@
-         self.generate_or_test(generate, f, 'contours.png')
-         f.close()
-+# see https://github.com/aplpy/aplpy/issues/278
-+    @pytest.mark.xfail()
-     # Test cube slice
-     def test_cube_slice(self, generate):
-         f = FITSFigure(self.filename_3, dimensions=[2, 0], slices=[10])
---- a/aplpy/tests/test_rgb.py
-+++ b/aplpy/tests/test_rgb.py
-@@ -6,6 +6,7 @@
- import numpy as np
- from astropy.io import fits
-+from astropy.tests.helper import pytest
- from .. import FITSFigure
- from ..rgb import make_rgb_image
-@@ -17,6 +18,8 @@
- class TestRGB(BaseImageTests):
-+# see https://github.com/aplpy/aplpy/issues/278
-+    @pytest.mark.xfail()
-     def test_rgb(self, generate, tmpdir):
-         # Regression test to check that RGB recenter works properly
---- a/aplpy/tests/test_vectors.py
-+++ b/aplpy/tests/test_vectors.py
-@@ -1,4 +1,5 @@
- import numpy as np
-+from astropy.tests.helper import pytest
- from ..core import FITSFigure
-@@ -15,6 +16,8 @@
- class TestVectors(BaseImageTests):
-+# see https://github.com/aplpy/aplpy/issues/278
-+    @pytest.mark.xfail()
-     def test_default(self, generate):
-         f = FITSFigure(IMAGE, figsize=(4,4))
-         f.show_grayscale()
-@@ -22,6 +25,8 @@
-         self.generate_or_test(generate, f, 'vectors_default.png', tolerance=2.5)
-         f.close()
-+# see https://github.com/aplpy/aplpy/issues/278
-+    @pytest.mark.xfail()
-     def test_step_scale(self, generate):
-         f = FITSFigure(IMAGE, figsize=(4,4))
-         f.show_grayscale()
diff --git a/dev-python/aplpy/metadata.xml b/dev-python/aplpy/metadata.xml
deleted file mode 100644 (file)
index 8fa6a8c..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-  <maintainer type="project">
-    <email>sci-astronomy@gentoo.org</email>
-    <name>Gentoo Astronomy Project</name>
-  </maintainer>
-  <longdescription lang="en">
-  APLpy (the Astronomical Plotting Library in Python) is a Python
-  module aimed at producing publication-quality plots of astronomical
-  imaging data in FITS format. The module uses Matplotlib. It is
-  capable of creating output files in several graphical formats,
-  including EPS, PDF, PS, PNG, and SVG.
-</longdescription>
-  <upstream>
-    <remote-id type="pypi">APLpy</remote-id>
-  </upstream>
-</pkgmetadata>