sys-apps/systemd: Export toolchain vars
authorMike Gilbert <floppym@gentoo.org>
Sun, 6 Sep 2015 01:31:38 +0000 (21:31 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sun, 6 Sep 2015 01:31:38 +0000 (21:31 -0400)
This prevents any i686 cross toolchain from being used for a multilib build.

Bug: https://bugs.gentoo.org/559726

Package-Manager: portage-2.2.20

sys-apps/systemd/systemd-225.ebuild
sys-apps/systemd/systemd-9999.ebuild

index 1a325de67930f11ea808362e310da1f72a402113..8e44315bcf96a68de21b53aeaddb2efcabeb4e99 100644 (file)
@@ -164,6 +164,9 @@ src_configure() {
        # Fix systems broken by bug #509454.
        [[ ${MY_UDEVDIR} ]] || MY_UDEVDIR=/lib/udev
 
+       # Prevent conflicts with i686 cross toolchain, bug 559726
+       tc-export AR CC NM OBJCOPY RANLIB
+
        multilib-minimal_src_configure
 }
 
index 1a325de67930f11ea808362e310da1f72a402113..8e44315bcf96a68de21b53aeaddb2efcabeb4e99 100644 (file)
@@ -164,6 +164,9 @@ src_configure() {
        # Fix systems broken by bug #509454.
        [[ ${MY_UDEVDIR} ]] || MY_UDEVDIR=/lib/udev
 
+       # Prevent conflicts with i686 cross toolchain, bug 559726
+       tc-export AR CC NM OBJCOPY RANLIB
+
        multilib-minimal_src_configure
 }