dev-python/python-sqlparse: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 09:05:38 +0000 (10:05 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 13:38:44 +0000 (14:38 +0100)
dev-python/python-sqlparse/Manifest
dev-python/python-sqlparse/python-sqlparse-0.2.1.ebuild [deleted file]
dev-python/python-sqlparse/python-sqlparse-0.2.2.ebuild [deleted file]

index 3f4d4b2973a7960d8f1c5f7b09d76d4e92a1c449..7071da999523ec523b01a3c92bf039568670ef79 100644 (file)
@@ -1,3 +1 @@
-DIST sqlparse-0.2.1.tar.gz 53463 BLAKE2B 5e729f58ec67f6dea8b02c9be23d8391e5312b9a1e5820fcf29e76ae567d7be62b4b6bda005f3662fe7feffc9c8f73d6cbbf320a87af719503a01228d1d8e3ce SHA512 8f70677c73cb3bb2ac11d6b90fd86f6f874b3ba4b402bb776f716d75103c3768c385dbe403290c167f76874e92c36ac4deb1ca3c5d5f6fbc69bed0935505d5ef
-DIST sqlparse-0.2.2.tar.gz 57965 BLAKE2B 861567c9acc4871c7b743fbe343011a3810fcc31e0d4c85619f743e4930066e18e4700c5b0c7a529f55f8010f748c3512b5d5b8641c35ab0be19d1ccd3fc6214 SHA512 8d812067364897e96c6ece28bae51983d5560db2be2ed23c6f16e718a9fea220fd9941970208bfbd64becae78f1a1e1c2603c4f3246319ec120ada71515ef5a1
 DIST sqlparse-0.2.3.tar.gz 60742 BLAKE2B 38d3f17d196d3a1d50ea75810b5bd3a890c6f4b12195621d571d62b8c40e2e2d13034deddd95288df37a15daba28153a5ca9221b78bfff1c0e3bc37eddca2dba SHA512 ec654e680f8ce423a89da92c4c74f85e652bebb19e9a40ab0b8067f61803897e49e1e6f8dd1ab454b1ed130974d76b4f973c799264fd4bf8a87f034ba9c44835
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.2.1.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.2.1.ebuild
deleted file mode 100644 (file)
index 554f45f..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
-
-inherit distutils-r1
-
-MY_PN="${PN##python-}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A non-validating SQL parser module for Python"
-HOMEPAGE="https://code.google.com/p/python-sqlparse/ https://github.com/andialbrecht/sqlparse"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-LICENSE="BSD-2"
-IUSE="doc test"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               )"
-# Required for running tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-S="${WORKDIR}"/${P#python-}
-
-pkg_setup() {
-       use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       if python_is_python3; then
-               2to3 -w --no-diffs -n tests/ sqlparse/
-               py.test ./tests || die "testsuite failed ${EPYTHON}"
-       else
-               py.test tests || die "testsuite failed under ${EPYTHON}"
-       fi
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.2.2.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.2.2.ebuild
deleted file mode 100644 (file)
index d45f7b3..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1
-
-MY_PN="${PN##python-}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A non-validating SQL parser module for Python"
-HOMEPAGE="https://code.google.com/p/python-sqlparse/ https://github.com/andialbrecht/sqlparse"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-LICENSE="BSD-2"
-IUSE="doc test"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               )"
-# Required for running tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-S="${WORKDIR}"/${P#python-}
-
-pkg_setup() {
-       use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       if python_is_python3; then
-               2to3 -w --no-diffs -n tests/ sqlparse/
-               py.test ./tests || die "testsuite failed ${EPYTHON}"
-       else
-               py.test tests || die "testsuite failed under ${EPYTHON}"
-       fi
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
-       distutils-r1_python_install_all
-}