sci-libs/octomap: Bump to 1.8.1 and install package.xml in our custom gentoo path...
authorAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 10:53:39 +0000 (11:53 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 11:26:51 +0000 (12:26 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-libs/octomap/Manifest
sci-libs/octomap/octomap-1.8.1.ebuild [new file with mode: 0644]
sci-libs/octomap/octomap-9999.ebuild

index 3d1141a38990f19841d33c1e7940d9b3beb24eb9..228b4b31400906d032f5dc657c522af004cf6b9a 100644 (file)
@@ -1 +1,2 @@
 DIST octomap-1.8.0.tar.gz 1584799 SHA256 158f66af55bb660a2aa7d0a00c60c9e5320f6594bd0924748af1471d315d5633 SHA512 61ceeee80de8bcdcfde69c3dd30a218ec7f9e4362b1bae8e80d29dde74875a717cc1cbcfba1a7c3ee7ec0ee954297796ac35052782b98af36448f5c3305bdfa9 WHIRLPOOL 12d1dd64d0b7999aa41c5ed878af63385f25536a32a38b28d168a10560dc6de5ce1148d6f20c310082da765066a8f3f826860f481ae11e1669aa9a15f6365b71
+DIST octomap-1.8.1.tar.gz 1679526 SHA256 8b18ef7693e87f1400b9a8bc41f86e3b28259ac98c0b458037232652380aa6af SHA512 e35567da0d6741747abbc87de49733d0e92bae8aedfe66a63766740cc6566f3cfdbc3c986369177497cc9a8fb208ed9b727da496cec48e2ad23328df06fbc8d6 WHIRLPOOL 7bad33e4bb01ef0d0599d4e7ea6b323e4aacb06d9f5e8d4a05b52aa0be72d205735402ed25f2ff3fcad6636f838124453f61bff1808fbe75154a4e7d32d1ded3
diff --git a/sci-libs/octomap/octomap-1.8.1.ebuild b/sci-libs/octomap/octomap-1.8.1.ebuild
new file mode 100644 (file)
index 0000000..a80cadc
--- /dev/null
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM="git-r3"
+       EGIT_REPO_URI="https://github.com/OctoMap/octomap"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+       KEYWORDS=""
+       SRC_URI=""
+else
+       KEYWORDS="~amd64 ~arm"
+       SRC_URI="https://github.com/OctoMap/octomap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="An Efficient Probabilistic 3D Mapping Framework Based on Octrees"
+HOMEPAGE="http://octomap.github.io/"
+IUSE="qt4 dynamicEDT3D doc"
+LICENSE="BSD qt4? ( GPL-2 )"
+SLOT="0"
+
+RDEPEND="
+       qt4? (
+               virtual/opengl
+               dev-qt/qtcore:4
+               dev-qt/qtgui:4
+               x11-libs/libQGLViewer:=
+       )
+"
+DEPEND="${RDEPEND}
+       doc? (
+               app-doc/doxygen
+               media-gfx/graphviz
+       )
+"
+
+src_prepare() {
+       sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
+               -i */CMakeLists.txt \
+               -i */CMakeModules/InstallPkgConfigFile.cmake || die
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               "-DBUILD_OCTOVIS_SUBPROJECT=$(usex qt4 ON OFF)"
+               "-DBUILD_DYNAMICETD3D_SUBPROJECT=$(usex dynamicEDT3D ON OFF)"
+       )
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+       if use doc ; then
+               cd "${BUILD_DIR}/octomap"
+               emake docs
+               if use dynamicEDT3D ; then
+                       cd "${BUILD_DIR}/dynamicEDT3D"
+                       emake docs_dynamicEDT3D
+               fi
+       fi
+}
+
+src_install() {
+       cmake-utils_src_install
+       if use doc ; then
+               insinto /usr/share/doc/${PF}/html/octomap
+               doins -r "${S}/octomap/doc/html/"*
+               if use dynamicEDT3D ; then
+                       insinto /usr/share/doc/${PF}/html/dynamicEDT3D
+                       doins -r "${S}/dynamicEDT3D/doc/html/"*
+               fi
+       fi
+
+       insinto /usr/share/ros_packages/${PN}
+       doins "${ED}/usr/share/${PN}/package.xml"
+       if use qt4; then
+               insinto /usr/share/ros_packages/octovis
+               doins "${ED}/usr/share/octovis/package.xml"
+       fi
+}
index 19df370fdb02fcd1fd209e40bbb048cba72318eb..a80cadce5c00c993a13bbef27aca49ffa5ff84c3 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -40,7 +40,6 @@ DEPEND="${RDEPEND}
                media-gfx/graphviz
        )
 "
-PATCHES=( "${FILESDIR}/gentoo.patch" )
 
 src_prepare() {
        sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
@@ -79,4 +78,11 @@ src_install() {
                        doins -r "${S}/dynamicEDT3D/doc/html/"*
                fi
        fi
+
+       insinto /usr/share/ros_packages/${PN}
+       doins "${ED}/usr/share/${PN}/package.xml"
+       if use qt4; then
+               insinto /usr/share/ros_packages/octovis
+               doins "${ED}/usr/share/octovis/package.xml"
+       fi
 }