app-office/abiword: Add patches back
authorDavid Seifert <soap@gentoo.org>
Sat, 18 Apr 2020 11:02:24 +0000 (13:02 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 18 Apr 2020 11:02:24 +0000 (13:02 +0200)
Closes: https://bugs.gentoo.org/717738
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: David Seifert <soap@gentoo.org>
app-office/abiword/Manifest
app-office/abiword/abiword-3.0.4.ebuild
app-office/abiword/files/abiword-3.0.4-enchant-2.patch [deleted file]

index c92d6517dae4fe82a07b7603835c83fa883efeb2..4d9271ca6948aaa219f628e07c52144407751239 100644 (file)
@@ -1 +1,2 @@
+DIST abiword-3.0.4-patchset.tar.gz 9143 BLAKE2B 143faaceab5e4a295876c04e26f38506429566cb9f42b0d41dfc4e40822b3cab647b128abe71da554cc12ac977987afbad131d7220dabeb1d10a28cc34592b35 SHA512 9fcf91d28402b9353d59ffb61aaeedce9d4e1be566eac05dc89866a0b0a5d5314c9ca030234b0c6514f35baab5b96fdf8cb63cf9d1d2cbcf01bd7adee89cecaa
 DIST abiword-3.0.4.tar.gz 11064305 BLAKE2B fda1732df0bf78f8830c5d68be18f2aec7f88b8d5bb4fe0effc31b48f03d9195a4337087154ba707a70d80bfcff38f92d7298e7b281afe2eacf000eca8dac9c4 SHA512 121708e010cef6722cab5622dc762f2f92c46e43b65b90b881b4f25ff32c1696fa2d281a3a6f2c04d5b9231bbbd0040281e9d4d7e594ec0ace6caae9c9021ec4
index 3142f1c8cda8780e9dccb0863bab0684c3ad5923..c8ab57891cf5eab00410543b1364a632498671e6 100644 (file)
@@ -7,7 +7,9 @@ inherit autotools xdg
 
 DESCRIPTION="Fully featured yet light and fast cross platform word processor"
 HOMEPAGE="http://www.abisource.com/"
-SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/source/${P}.tar.gz"
+SRC_URI="
+       http://www.abisource.com/downloads/${PN}/${PV}/source/${P}.tar.gz
+       https://dev.gentoo.org/~soap/distfiles/${P}-patchset.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="2"
@@ -65,9 +67,12 @@ BDEPEND="
        virtual/pkgconfig"
 
 PATCHES=(
-       # Backport of hard dep on enchant-2
-       # https://gitlab.gnome.org/World/AbiWord/commit/ae05e92df5a5d6151641622c83d35a6fdba47b1f
-       "${FILESDIR}"/${P}-enchant-2.patch
+       "${WORKDIR}"/patches/${PN}-2.6.0-boolean.patch
+       "${WORKDIR}"/patches/${PN}-2.8.3-desktop.patch
+       "${WORKDIR}"/patches/${PN}-3.0.0-librevenge.patch
+       "${WORKDIR}"/patches/${PN}-3.0.2-explicit-python.patch
+       "${WORKDIR}"/patches/${PN}-3.0.4-enchant-2.patch # backport
+       "${WORKDIR}"/patches/${PN}-3.0.4-pygobject.patch
 )
 
 src_prepare() {
diff --git a/app-office/abiword/files/abiword-3.0.4-enchant-2.patch b/app-office/abiword/files/abiword-3.0.4-enchant-2.patch
deleted file mode 100644 (file)
index 3ded360..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-From ae05e92df5a5d6151641622c83d35a6fdba47b1f Mon Sep 17 00:00:00 2001
-From: Hubert Figuiere <hub@figuiere.net>
-Date: Fri, 22 Nov 2019 20:02:52 -0500
-Subject: [PATCH] Require enchant 2 now
-
----
- configure.ac                      | 2 +-
- src/af/xap/xp/enchant_checker.cpp | 6 +++---
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index f2e392f04..3e1697ced 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -94,7 +94,7 @@
- "
- # optional deps
--enchant_req='enchant >= 1.2.0'
-+enchant_req='enchant-2'
- gio_req='gio-2.0'
- goffice_req='libgoffice-0.10 >= 0.10.0'
---- a/src/af/xap/xp/enchant_checker.cpp
-+++ b/src/af/xap/xp/enchant_checker.cpp
-@@ -127,7 +127,7 @@
-                               pvSugg->addItem (ucszSugg);
-               }
--              enchant_dict_free_suggestions (m_dict, suggestions);
-+              enchant_dict_free_string_list(m_dict, suggestions);
-       }
-       return pvSugg;
-@@ -139,7 +139,7 @@
-       if (word && len) {
-               UT_UTF8String utf8 (word, len);
--              enchant_dict_add_to_personal (m_dict, utf8.utf8_str(), utf8.byteLength());
-+              enchant_dict_add(m_dict, utf8.utf8_str(), utf8.byteLength());
-               return true;
-       }
-       return false;
-@@ -150,7 +150,7 @@
-       UT_return_val_if_fail (m_dict, false);
-       UT_UTF8String ignore (toCorrect, toCorrectLen);
--      return enchant_dict_is_in_session (m_dict, ignore.utf8_str(), ignore.byteLength()) != 0;
-+      return enchant_dict_is_added(m_dict, ignore.utf8_str(), ignore.byteLength()) != 0;
- }
- void EnchantChecker::ignoreWord (const UT_UCSChar *toCorrect, size_t toCorrectLen)
--- 
-2.24.1