sys-apps/portage: add zstd USE flag
authorIan Leonard <antonlacon@gmail.com>
Sat, 25 Apr 2020 20:32:57 +0000 (13:32 -0700)
committerZac Medico <zmedico@gentoo.org>
Tue, 5 May 2020 23:56:43 +0000 (16:56 -0700)
The zstd USE flag sets the default binary package compression to use
zstd and adds it as a dependency.

Masked on riscv until app-arch/zstd is keyworded.

Closes: https://github.com/gentoo/gentoo/pull/15520
Bug: https://bugs.gentoo.org/715108
Bug: https://bugs.gentoo.org/719456
Signed-off-by: Ian Leonard <antonlacon@gmail.com>
Signed-off-by: Zac Medico <zmedico@gentoo.org>
profiles/arch/riscv/package.use.mask
sys-apps/portage/portage-9999.ebuild

index 0d4cb1e3de58b60e269c4d11684e0629005388eb..bb0fdc58ad0c7bbe2655b9ba3d88facf36875cea 100644 (file)
@@ -1,6 +1,10 @@
 # Copyright 2019-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
+# Zac Medico <zmedico@gentoo.org> (2020-05-05)
+# Mask until app-arch/zstd is keyworded
+sys-apps/portage zstd
+
 # Patrick McLean <chutzpah@gentoo.org> (2020-04-16)
 # Lots of python dependencies, mask to facilitate keywording
 # keywording dev-libs/libfido2
index f581cb8ae977b9118e574d6963a7232b41e4426f..4134cca8ce9249c8e29507004e1d4e1dfe466f2b 100644 (file)
@@ -15,7 +15,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
 LICENSE="GPL-2"
 KEYWORDS=""
 SLOT="0"
-IUSE="apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
+IUSE="apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr zstd"
 
 DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
        >=app-arch/tar-1.27
@@ -54,6 +54,7 @@ RDEPEND="
        xattr? ( kernel_linux? (
                >=sys-apps/install-xattr-0.3
        ) )
+       zstd? ( app-arch/zstd )
        !<app-admin/logrotate-3.8.0"
 PDEPEND="
        !build? (
@@ -115,6 +116,12 @@ python_prepare_all() {
                        || die "failed to append to make.globals"
        fi
 
+       if use zstd ; then
+               einfo "Adding BINGPKG_COMPRESS=\"zstd\" to make.globals ..."
+               echo -e '\nBINGPKG_COMPRESS="zstd"' >> cnf/make.globals \
+                       || die "failed to append to make.globals"
+       fi
+
        if use build || ! use rsync-verify; then
                sed -e '/^sync-rsync-verify-metamanifest/s|yes|no|' \
                        -i cnf/repos.conf || die "sed failed"