Version bump.
authorMike Kelly <pioto@gentoo.org>
Sat, 24 Feb 2007 07:03:48 +0000 (07:03 +0000)
committerMike Kelly <pioto@gentoo.org>
Sat, 24 Feb 2007 07:03:48 +0000 (07:03 +0000)
Package-Manager: portage-2.1.2-r10

app-editors/gvim/ChangeLog
app-editors/gvim/files/digest-gvim-7.0.201 [new file with mode: 0644]
app-editors/gvim/gvim-7.0.201.ebuild [new file with mode: 0644]
app-editors/vim/ChangeLog
app-editors/vim/files/digest-vim-7.0.201 [new file with mode: 0644]
app-editors/vim/vim-7.0.201.ebuild [new file with mode: 0644]

index 01a91be732be20157e3c3efc667f5fcf88d79992..808b2a8a28330fefbb99ded2d082f307ddbe4230 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for app-editors/gvim
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.218 2007/02/21 20:42:21 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.219 2007/02/24 07:03:48 pioto Exp $
+
+*gvim-7.0.201 (24 Feb 2007)
+
+  24 Feb 2007; Mike Kelly <pioto@gentoo.org> +gvim-7.0.201.ebuild:
+  Version bump.
 
   21 Feb 2007; Markus Rothe <corsair@gentoo.org> gvim-7.0.174.ebuild:
   Stable on ppc64; bug #167816
diff --git a/app-editors/gvim/files/digest-gvim-7.0.201 b/app-editors/gvim/files/digest-gvim-7.0.201
new file mode 100644 (file)
index 0000000..d99c804
--- /dev/null
@@ -0,0 +1,9 @@
+MD5 a55e36b3c7a21a5835a35574d1f6595e vim-7.0-gentoo-patches-r1.tar.bz2 6749
+RMD160 88cead14b07bc3b7113a3e60f2b358caf501c789 vim-7.0-gentoo-patches-r1.tar.bz2 6749
+SHA256 17934badbe1288149a31ac309c17b579a0c33a409b5928a759620631c4a1ec7c vim-7.0-gentoo-patches-r1.tar.bz2 6749
+MD5 e8c8bb2b5c03f49d40e9736b7d479b9b vim-7.0-r1.tar.bz2 6117202
+RMD160 d24982a1b802dad9955940365665163a4641fd74 vim-7.0-r1.tar.bz2 6117202
+SHA256 e7383b2dfdc6f6df52fb45599eb6c5dc9037b1d3a4077bfe770cb98440b2589e vim-7.0-r1.tar.bz2 6117202
+MD5 2510c4704c38fccb1c0d3bcc5ff4f30f vim-patches-7.0.201.tar.gz 291618
+RMD160 62bcbd2a6ae0d1967e18eb62523c0141adce1c36 vim-patches-7.0.201.tar.gz 291618
+SHA256 031444112de567319e730b1de48fbb3188a0c843350840cd951c51d9d39c1ad6 vim-patches-7.0.201.tar.gz 291618
diff --git a/app-editors/gvim/gvim-7.0.201.ebuild b/app-editors/gvim/gvim-7.0.201.ebuild
new file mode 100644 (file)
index 0000000..0f22a76
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.0.201.ebuild,v 1.1 2007/02/24 07:03:48 pioto Exp $
+
+inherit vim
+
+VIM_VERSION="7.0"
+VIM_SNAPSHOT="vim-7.0-r1.tar.bz2"
+VIM_GENTOO_PATCHES="vim-7.0-gentoo-patches-r1.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+GVIMRC_FILE_SUFFIX="-r1"
+
+SRC_URI="${SRC_URI}
+       mirror://gentoo/${VIM_SNAPSHOT}
+       mirror://gentoo/${VIM_GENTOO_PATCHES}
+       mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.*}
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aqua gnome gtk motif nextaw"
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+       ~app-editors/vim-core-${PV}
+       || ( x11-libs/libXext virtual/x11 )
+       !aqua? (
+               gtk? (
+                       >=x11-libs/gtk+-2.6
+                       virtual/xft
+                       gnome? ( >=gnome-base/libgnomeui-2.6 )
+               )
+               !gtk? (
+                       motif? (
+                               x11-libs/openmotif
+                       )
+                       !motif? (
+                               nextaw? (
+                                       x11-libs/neXtaw
+                               )
+                               !nextaw? (
+                                       || ( x11-libs/libXaw virtual/x11 )
+                               )
+                       )
+               )
+       )"
index b37e614c7554474f70c7a85ce440391fbffac15c..151b53444cf642871233451fdfaae1d595a1471f 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for app-editors/vim
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.257 2007/02/21 20:40:26 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.258 2007/02/24 07:01:27 pioto Exp $
+
+*vim-7.0.201 (24 Feb 2007)
+
+  24 Feb 2007; Mike Kelly <pioto@gentoo.org> +vim-7.0.201.ebuild:
+  Version bump.
 
   21 Feb 2007; Markus Rothe <corsair@gentoo.org> vim-7.0.174.ebuild:
   Stable on ppc64; bug #167816
diff --git a/app-editors/vim/files/digest-vim-7.0.201 b/app-editors/vim/files/digest-vim-7.0.201
new file mode 100644 (file)
index 0000000..d99c804
--- /dev/null
@@ -0,0 +1,9 @@
+MD5 a55e36b3c7a21a5835a35574d1f6595e vim-7.0-gentoo-patches-r1.tar.bz2 6749
+RMD160 88cead14b07bc3b7113a3e60f2b358caf501c789 vim-7.0-gentoo-patches-r1.tar.bz2 6749
+SHA256 17934badbe1288149a31ac309c17b579a0c33a409b5928a759620631c4a1ec7c vim-7.0-gentoo-patches-r1.tar.bz2 6749
+MD5 e8c8bb2b5c03f49d40e9736b7d479b9b vim-7.0-r1.tar.bz2 6117202
+RMD160 d24982a1b802dad9955940365665163a4641fd74 vim-7.0-r1.tar.bz2 6117202
+SHA256 e7383b2dfdc6f6df52fb45599eb6c5dc9037b1d3a4077bfe770cb98440b2589e vim-7.0-r1.tar.bz2 6117202
+MD5 2510c4704c38fccb1c0d3bcc5ff4f30f vim-patches-7.0.201.tar.gz 291618
+RMD160 62bcbd2a6ae0d1967e18eb62523c0141adce1c36 vim-patches-7.0.201.tar.gz 291618
+SHA256 031444112de567319e730b1de48fbb3188a0c843350840cd951c51d9d39c1ad6 vim-patches-7.0.201.tar.gz 291618
diff --git a/app-editors/vim/vim-7.0.201.ebuild b/app-editors/vim/vim-7.0.201.ebuild
new file mode 100644 (file)
index 0000000..caea218
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.0.201.ebuild,v 1.1 2007/02/24 07:01:27 pioto Exp $
+
+inherit vim
+
+VIM_VERSION="7.0"
+VIM_SNAPSHOT="vim-7.0-r1.tar.bz2"
+VIM_GENTOO_PATCHES="vim-7.0-gentoo-patches-r1.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+
+SRC_URI="${SRC_URI}
+       mirror://gentoo/${VIM_SNAPSHOT}
+       mirror://gentoo/${VIM_GENTOO_PATCHES}
+       mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.*}
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+       !minimal? ( ~app-editors/vim-core-${PV} )"
+RDEPEND="${RDEPEND}
+       !<app-editors/nvi-1.81.5-r4
+       !minimal? ( ~app-editors/vim-core-${PV} )"