dev-libs/jsoncpp: Fix build on arm, bug #552572
authorJohannes Huber <johu@gentoo.org>
Mon, 10 Aug 2015 19:57:53 +0000 (21:57 +0200)
committerJohannes Huber <johu@gentoo.org>
Mon, 10 Aug 2015 19:58:35 +0000 (21:58 +0200)
Adds upstream patch commit: 96412d2964775fd6fb9bf359936743dd508af8ba

Gentoo-bug: 552572
Acked-by: Markus Meier <maekke@gentoo.org>
Acked-by: Michał Górny <mgorny@gentoo.org>
Package-Manager: portage-2.2.20

dev-libs/jsoncpp/files/jsoncpp-0.10.2-arm.patch [new file with mode: 0644]
dev-libs/jsoncpp/jsoncpp-0.10.2-r1.ebuild

diff --git a/dev-libs/jsoncpp/files/jsoncpp-0.10.2-arm.patch b/dev-libs/jsoncpp/files/jsoncpp-0.10.2-arm.patch
new file mode 100644 (file)
index 0000000..838ef84
--- /dev/null
@@ -0,0 +1,25 @@
+From 96412d2964775fd6fb9bf359936743dd508af8ba Mon Sep 17 00:00:00 2001
+From: Christopher Dunn <cdunn2001@gmail.com>
+Date: Wed, 10 Jun 2015 21:22:24 -0500
+Subject: [PATCH] fix #290
+
+(cherry picked from commit 2760c7902a5cc7173aabe4e1f31dcf93e79377d5)
+---
+ src/test_lib_json/main.cpp | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/test_lib_json/main.cpp b/src/test_lib_json/main.cpp
+index 85110ad..080ba6e 100644
+--- a/src/test_lib_json/main.cpp
++++ b/src/test_lib_json/main.cpp
+@@ -296,7 +296,10 @@ JSONTEST_FIXTURE(ValueTest, null) {
+   JSONTEST_ASSERT_EQUAL(0.0, null_.asFloat());
+   JSONTEST_ASSERT_STRING_EQUAL("", null_.asString());
++#if !defined(__ARMEL__)
++  // See line #165 of include/json/value.h
+   JSONTEST_ASSERT_EQUAL(Json::Value::null, null_);
++#endif
+ }
+ JSONTEST_FIXTURE(ValueTest, strings) {
index 08d77345b80ebbed2e2a5ec6ac9b2b196c1a99ba..e6c618b40d0789bf84c4f931809097c046ef9540 100644 (file)
@@ -29,6 +29,7 @@ RDEPEND=""
 PATCHES=(
        # fix broken path subst in .pc file
        "${FILESDIR}"/jsoncpp-1.6.2-fix-pkgconfig.patch
+       "${FILESDIR}/${P}-arm.patch"
 )
 
 pkg_setup() {