sys-fs/bees: Bump to v0.6.1
authorKai Krakow <kai@kaishome.de>
Sun, 18 Nov 2018 15:21:28 +0000 (16:21 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 18 Jun 2019 05:40:04 +0000 (07:40 +0200)
This removes the quickfix in the ebuild and should fix a compiler
problem linked below.

Closes: https://bugs.gentoo.org/670606
Closes: https://bugs.gentoo.org/686976
Closes: https://bugs.gentoo.org/686978
Closes: https://bugs.gentoo.org/687978
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Kai Krakow <kai@kaishome.de>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-fs/bees/Manifest
sys-fs/bees/bees-0.6.1.ebuild [new file with mode: 0644]

index 68efaffe866d3062a9ecb169defd1cda95ab970d..c28f6419f1cb9372d711a3b56cd9f2224be8a898 100644 (file)
@@ -1 +1,2 @@
+DIST bees-0.6.1.tar.gz 124411 BLAKE2B fd6c875334cb610da94a4633351b7edc5a4ecf4ff467bb93c8559a1698fd29667d43955e0031498401ceeb3d8db13b5aeb80d2f16cd61e4d5a6607e432082c79 SHA512 cd44d21959d3ab4dda255f0a4a57bd3aeecfb9fee6ea26d68a1b5f84d407f75bd0b442ecf4fefc5ac856dcd9af035f44ceeff77a8926b164f97a15350efcee33
 DIST bees-0.6.tar.gz 124049 BLAKE2B 7a2d77366758325cebbc51767781a3eff4fa52180b53ebf5eb982433bfc1c80acd4f3befa5968c888be443815e6231625e9ecc2763c35e33e5ed55c13bd702bc SHA512 bb288da8d2e0fad100dc40e3f9060055220e0ec948bc571a1cb06a7d78d0d0e6db30164e7dbde040c264c496cb59d50bb0694dd9432a8229e04f2cdc33bab31d
diff --git a/sys-fs/bees/bees-0.6.1.ebuild b/sys-fs/bees/bees-0.6.1.ebuild
new file mode 100644 (file)
index 0000000..a232eb5
--- /dev/null
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+DESCRIPTION="Best-Effort Extent-Same, a btrfs dedup agent"
+HOMEPAGE="https://github.com/Zygo/bees"
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/Zygo/bees.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/Zygo/bees/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="tools"
+
+DEPEND="
+       >=sys-apps/util-linux-2.30.2
+       >=sys-fs/btrfs-progs-4.1
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~BTRFS_FS"
+ERROR_BTRFS_FS="CONFIG_BTRFS_FS: bees does currently only work with btrfs"
+
+pkg_pretend() {
+       if [[ ${MERGE_TYPE} != buildonly ]]; then
+               if kernel_is -lt 4 4 3; then
+                       ewarn "Kernel versions below 4.4.3 lack critical features needed for bees to"
+                       ewarn "properly operate, so it won't work. It's recommended to run at least"
+                       ewarn "kernel version 4.11 for best performance and reliability."
+                       ewarn
+               elif kernel_is -lt 4 11; then
+                       ewarn "With kernel versions below 4.11, bees may severely degrade system performance"
+                       ewarn "and responsiveness. Especially, the kernel may deadlock while bees is"
+                       ewarn "running, it's recommended to run at least kernel 4.11."
+                       ewarn
+               elif kernel_is -lt 4 14 29; then
+                       ewarn "With kernel versions below 4.14.29, bees may generate a lot of bogus WARN_ON()"
+                       ewarn "messages in the kernel log. These messages can be ignored and this is fixed"
+                       ewarn "with more recent kernels:"
+                       ewarn "# WARNING: CPU: 3 PID: 18172 at fs/btrfs/backref.c:1391 find_parent_nodes+0xc41/0x14e0"
+                       ewarn
+               fi
+               elog "Bees recommends to run the latest current kernel for performance and"
+               elog "reliability reasons, see README.md."
+       fi
+}
+
+src_configure() {
+       cat >localconf <<-EOF || die
+               LIBEXEC_PREFIX=/usr/libexec
+               PREFIX=/usr
+               LIBDIR="$(get_libdir)"
+               SYSTEMD_SYSTEM_UNIT_DIR="$(systemd_get_systemunitdir)"
+               DEFAULT_MAKE_TARGET=all
+       EOF
+       if [[ ${PV} != "9999" ]] ; then
+               cat >>localconf <<-EOF || die
+                       BEES_VERSION=v${PV}
+               EOF
+       fi
+       if use tools; then
+               echo OPTIONAL_INSTALL_TARGETS=install_tools >>localconf || die
+       fi
+}