dev-vcs/python-gitlab: python command line interface to the gitlab API
authorWilliam Hubbs <williamh@gentoo.org>
Thu, 31 Jan 2019 23:51:29 +0000 (17:51 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Thu, 31 Jan 2019 23:52:47 +0000 (17:52 -0600)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: William Hubbs <williamh@gentoo.org>
dev-vcs/python-gitlab/Manifest [new file with mode: 0644]
dev-vcs/python-gitlab/metadata.xml [new file with mode: 0644]
dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild [new file with mode: 0644]

diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
new file mode 100644 (file)
index 0000000..e05c6e1
--- /dev/null
@@ -0,0 +1 @@
+DIST python-gitlab-1.7.0.tar.gz 110657 BLAKE2B 1003d3373d3ef5474b1d5c10b1c6af57e7467cec432fc1eb75b4e1ba7766361641f25461ac2bf1b7692dab855d4e5cbc204240ede3568e71ed1af75682807fb0 SHA512 ad50d989e27948ff5188f4191ad3b7f1e1b45608627b2042bf02d635b2aa8da0a24f6b0383f483a01df54e4ab14576e7e4252576b9c2bdf67a187ae6aad69d53
diff --git a/dev-vcs/python-gitlab/metadata.xml b/dev-vcs/python-gitlab/metadata.xml
new file mode 100644 (file)
index 0000000..c36c371
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>williamh@gentoo.org</email>
+               <name>William Hubbs</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild
new file mode 100644 (file)
index 0000000..2ee27c7
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+if [[ ${PV} = *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/testrepository[${PYTHON_USEDEP}]
+               dev-python/hacking[${PYTHON_USEDEP}]
+               dev-python/httmock[${PYTHON_USEDEP}]
+               dev-python/jinja[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.3
+               dev-python/sphinx_rtd_theme )"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]"
+
+python_install_all() {
+       distutils-r1_python_install_all
+       dodoc -r *.rst docs
+}