dev-qt/qtgui: Fix build with CXXFLAGS="-march=native"
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 15 Sep 2019 16:44:13 +0000 (18:44 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 15 Sep 2019 16:51:41 +0000 (18:51 +0200)
Old fix from 5.12.1 still applies.

Reported-by: PhobosK <phobosk@fastmail.fm>
Bug: https://bugs.gentoo.org/672946
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-qt/qtgui/qtgui-5.12.5.ebuild

index aa6a1274d224e912f5440f46933207dd971c8d47..c8c5675f6c317df9662e76fd4fdfcf2c19d419af 100644 (file)
@@ -124,6 +124,8 @@ QT5_GENTOO_PRIVATE_CONFIG=(
        :gui
 )
 
+PATCHES+=( "${FILESDIR}/qt-5.12-gcc-avx2.patch" ) # bug 672946
+
 src_prepare() {
        # don't add -O3 to CXXFLAGS, bug 549140
        sed -i -e '/CONFIG\s*+=/s/optimize_full//' src/gui/gui.pro || die