net-analyzer/iptraf-ng: Update live ebuild
authorJeroen Roovers <jer@gentoo.org>
Tue, 5 Nov 2019 20:28:06 +0000 (21:28 +0100)
committerJeroen Roovers <jer@gentoo.org>
Tue, 5 Nov 2019 20:29:55 +0000 (21:29 +0100)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/iptraf-ng/iptraf-ng-1.1.4-r3.ebuild
net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild

index 2d069e16ad8824837bd5ca934291cc31743dbae1..b068ef51aeb0130b2ce937eaa7918e8779cc006c 100644 (file)
@@ -47,7 +47,7 @@ src_prepare() {
 }
 
 src_configure() {
-       # configure does not do very much we do not already control
+       # The configure script does not do very much we do not already control
        append-cppflags '-DLOCKDIR=\"/run/lock/iptraf-ng\"'
        tc-export CC
 }
@@ -57,6 +57,7 @@ src_install() {
 
        doman src/*.8
        dodoc AUTHORS CHANGES FAQ README* RELEASE-NOTES
+
        if use doc; then
                docinto html
                dodoc -r Documentation/*
index 284d4bb322e47d3a8f6e20c886bed832a9483154..4c2ce0db62b97d38e2a6bb448c3b08f827647c4c 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-inherit git-r3 toolchain-funcs
+inherit flag-o-matic git-r3 toolchain-funcs
 
 DESCRIPTION="A console-based network monitoring utility"
 HOMEPAGE="https://github.com/iptraf-ng/iptraf-ng"
@@ -13,8 +13,6 @@ SLOT="0"
 KEYWORDS=""
 IUSE="doc"
 
-RESTRICT="test"
-
 RDEPEND="
        >=sys-libs/ncurses-5.7-r7:0=
 "
@@ -23,10 +21,9 @@ DEPEND="
        virtual/os-headers
        !net-analyzer/iptraf
 "
+RESTRICT="test"
 
 src_prepare() {
-       default
-
        sed -i \
                -e '/^CC =/d' \
                -e '/^CFLAGS/s:= -g -O2:+= :' \
@@ -40,15 +37,14 @@ src_prepare() {
                -e 's|rvnamed|&-ng|g' \
                -e 's|RVNAMED|&-NG|g' \
                src/*.8 || die
-}
 
-# configure does not do very much we do not already control
-src_configure() { :; }
+       default
+}
 
-src_compile() {
+src_configure() {
+       # The configure script does not do very much we do not already control
+       append-cppflags '-DLOCKDIR=\"/run/lock/iptraf-ng\"'
        tc-export CC
-       CFLAGS+=' -DLOCKDIR=\"/run/lock/iptraf-ng\"'
-       default
 }
 
 src_install() {
@@ -59,7 +55,7 @@ src_install() {
 
        if use doc; then
                docinto html
-               dodoc -r Documentation
+               dodoc -r Documentation/*
        fi
 
        keepdir /var/{lib,log}/iptraf-ng #376157