dev-libs/libixion: Fix bashisms in configure.ac, --disable-static
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 28 May 2020 16:59:00 +0000 (18:59 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 28 May 2020 17:09:02 +0000 (19:09 +0200)
Reported-by: Matt Whitlock <gentoo@mattwhitlock.name>
Thanks-to: Lars Wendler <polynomial-c@gentoo.org>
Closes: https://bugs.gentoo.org/723128
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/libixion/files/libixion-0.15.0-bashism.patch [new file with mode: 0644]
dev-libs/libixion/libixion-0.15.0.ebuild
dev-libs/libixion/libixion-9999.ebuild

diff --git a/dev-libs/libixion/files/libixion-0.15.0-bashism.patch b/dev-libs/libixion/files/libixion-0.15.0-bashism.patch
new file mode 100644 (file)
index 0000000..9df7b04
--- /dev/null
@@ -0,0 +1,32 @@
+From 076f6576e7398842457d34fd68140512795c7e00 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Fri, 15 May 2020 12:42:20 +0200
+Subject: [PATCH] configure.ac: avoid bashisms
+
+or else we end up with unpredictable results if shell != /bin/bash:
+
+  ./configure: 19427: test: xno: unexpected operator
+
+Reported-by: Matt Whitlock <gentoo@mattwhitlock.name>
+Gentoo-bug: https://bugs.gentoo.org/723128
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 3a07dd8..505aeba 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -182,7 +182,7 @@ AC_ARG_ENABLE([werror],
+       [enable_werror="$enableval"],
+       [enable_werror=no]
+ )
+-AS_IF([test x"$enable_werror" == "xyes"], [
++AS_IF([test x"$enable_werror" = "xyes"], [
+       CXXFLAGS="$CXXFLAGS -Werror"
+ ])
+-- 
+2.26.2
+
index d3155185dc5a4a1add4de4622a73c03aa552a432..b93481abbcaf65c2582577da3092f829df9d7248 100644 (file)
@@ -4,14 +4,14 @@
 EAPI=7
 
 PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1
+inherit autotools python-single-r1
 
 DESCRIPTION="General purpose formula parser & interpreter"
 HOMEPAGE="https://gitlab.com/ixion/ixion"
 
 if [[ ${PV} == *9999 ]]; then
        EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
-       inherit git-r3 autotools
+       inherit git-r3
 else
        SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
        KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~x86"
@@ -19,7 +19,7 @@ fi
 
 LICENSE="MIT"
 SLOT="0/0.15" # based on SONAME of libixion.so
-IUSE="debug python static-libs +threads"
+IUSE="debug python +threads"
 
 REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
 
@@ -32,7 +32,10 @@ DEPEND="${RDEPEND}
        dev-libs/spdlog
 "
 
-PATCHES=( "${FILESDIR}/${P}-musl-clang.patch" ) # bug 714018
+PATCHES=(
+       "${FILESDIR}/${P}-musl-clang.patch" # bug 714018
+       "${FILESDIR}/${P}-bashism.patch" # bug 723128
+)
 
 pkg_setup() {
        use python && python-single-r1_pkg_setup
@@ -40,14 +43,14 @@ pkg_setup() {
 
 src_prepare() {
        default
-       [[ ${PV} == *9999 ]] && eautoreconf
+       eautoreconf
 }
 
 src_configure() {
        local myeconfargs=(
+               --disable-static
                $(use_enable debug)
                $(use_enable python)
-               $(use_enable static-libs static)
                $(use_enable threads)
        )
        econf "${myeconfargs[@]}"
index 28084226f1e7c19161e4170165061046ee77d805..e3b55ff9101273db6dd5afd2c7100a4f12e23d0c 100644 (file)
@@ -21,7 +21,7 @@ fi
 
 LICENSE="MIT"
 SLOT="0/0.16" # based on SONAME of libixion.so
-IUSE="debug python static-libs +threads"
+IUSE="debug python +threads"
 
 REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
 
@@ -45,9 +45,9 @@ src_prepare() {
 
 src_configure() {
        local myeconfargs=(
+               --disable-static
                $(use_enable debug)
                $(use_enable python)
-               $(use_enable static-libs static)
                $(use_enable threads)
        )
        econf "${myeconfargs[@]}"