sys-libs/libcap: Removed old
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 4 Mar 2020 09:52:41 +0000 (10:52 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 4 Mar 2020 10:03:56 +0000 (11:03 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-libs/libcap/Manifest
sys-libs/libcap/libcap-2.31.ebuild [deleted file]

index f4dcbecfadecba0c9fb1bb7a39a9fa523bebb6a1..e603b8d4cd143812ef12cde30939cf3886b70f92 100644 (file)
@@ -1,5 +1,4 @@
 DIST libcap-2.26.tar.xz 67172 BLAKE2B 9d1952bd03e1bba5ffa225a5088b8d841c2007219bbb9524f979ac65e472bf932db496acf93984fa77fe42e71d45b85cd603ca461a071fb4742526dfbc5f66eb SHA512 1c2d59f007226405a924950b2c2090393527e06f0692a84e6463e33915a070df61a9070b8f30a624d5630ddd39290eac117e5d440577d1edd48510195b9d12f0
 DIST libcap-2.27.tar.xz 67780 BLAKE2B 7b58d7afdd90281771a302cd9554f067b9e3636b0c052935973d8a0d890490c3933b3513874b788a8c10e37ab5ad9cfa766408c9629b7c8562cb17bfdef87747 SHA512 e32335fd3e0d1564574acc73df7030b5b0fd98875217bffabd76f2765f1a7a6f1369f03df2ee22a1782776838784e342378c10613ea1163d53ae5055ab6a62b6
-DIST libcap-2.31.tar.xz 99236 BLAKE2B c4cd5e2e105cc05b2aee2ee6435b9a28c06a91dee5cdd1baf6d94f625d89e134ad35a4493ffdfda7f3ffb0b41aa6e75a20cd705bfe9df570e82d0b6ea4e484e1 SHA512 9f0ef665a52e77356d6028abdead3c3cf75f97406ac09d60a33500222428c581d8aaa7d25d7eb9051d9c73ebfaefa7af5581430e1ecc1dfea73398a3ac7cbc3a
 DIST libcap-2.32.tar.xz 99708 BLAKE2B cbd4676ca9ada4c4dd6dee5137c0bb16f23af5d9a224c81b476c19326f87352fb06e2e123c9431558cd22f91032064ed6de8407d5861728dd141be16957363db SHA512 e2325cf0a1d0509c49336f7e5760e5b339c889cdde8d6c359197aed711423f951ad390a2a3dd4943b03afe152ad8502ea1db9d7ef247148b93e93a3c4895a019
 DIST libcap-2.33.tar.xz 111280 BLAKE2B 9a34b6e871c6175da5ef665ab7a5ed8b9889f598875f58a6e0b7aef9b6b2737f2a85bb0a6e259a730a3fcea3b8ebbec793b52ee5dec7d11fcf236dfb2148eb83 SHA512 bb5bdc1318b524ee607026038dff7c1c621f1710fa07f8c341b1f86761cb086d32b93d7a12dbe4256d4440ee984143db8659d2679330e221ce184d7048c142b4
diff --git a/sys-libs/libcap/libcap-2.31.ebuild b/sys-libs/libcap/libcap-2.31.ebuild
deleted file mode 100644 (file)
index 019cf1b..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib multilib-minimal toolchain-funcs pam usr-ldscript
-
-DESCRIPTION="POSIX 1003.1e capabilities"
-HOMEPAGE="https://sites.google.com/site/fullycapable/"
-SRC_URI="https://www.kernel.org/pub/linux/libs/security/linux-privs/libcap2/${P}.tar.xz"
-
-# it's available under either of the licenses
-LICENSE="|| ( GPL-2 BSD )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="pam static-libs"
-
-# While the build system optionally uses gperf, we don't DEPEND on it because
-# the build automatically falls back when it's unavailable.  #604802
-RDEPEND=">=sys-apps/attr-2.4.47-r1[${MULTILIB_USEDEP}]
-       pam? ( sys-libs/pam[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
-       sys-kernel/linux-headers"
-
-# Requires test suite being run as root (via sudo)
-RESTRICT="test"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-2.29-build-system-fixes.patch
-       "${FILESDIR}"/${PN}-2.28-no_perl.patch
-       "${FILESDIR}"/${PN}-2.25-ignore-RAISE_SETFCAP-install-failures.patch
-       "${FILESDIR}"/${PN}-2.21-include.patch
-)
-
-src_prepare() {
-       default
-       multilib_copy_sources
-}
-
-run_emake() {
-       local args=(
-               exec_prefix="${EPREFIX}"
-               lib_prefix="${EPREFIX}/usr"
-               lib="$(get_libdir)"
-               prefix="${EPREFIX}/usr"
-               PAM_CAP="$(usex pam yes no)"
-               DYNAMIC=yes
-               GOLANG=no
-       )
-       emake "${args[@]}" "$@"
-}
-
-multilib_src_compile() {
-       tc-export AR CC RANLIB
-       local BUILD_CC
-       tc-export_build_env BUILD_CC
-
-       run_emake
-}
-
-multilib_src_install() {
-       # no configure, needs explicit install line #444724#c3
-       run_emake DESTDIR="${D}" install
-
-       gen_usr_ldscript -a cap
-       if ! use static-libs ; then
-               # Don't remove libpsx.a!
-               # See https://bugs.gentoo.org/703912
-               rm "${ED}"/usr/$(get_libdir)/libcap.a || die
-       fi
-
-       if [[ -d "${ED}"/usr/$(get_libdir)/security ]] ; then
-               rm -r "${ED}"/usr/$(get_libdir)/security || die
-       fi
-
-       if use pam; then
-               dopammod pam_cap/pam_cap.so
-               dopamsecurity '' pam_cap/capability.conf
-       fi
-}
-
-multilib_src_install_all() {
-       dodoc CHANGELOG README doc/capability.notes
-}