app-misc/transfolio: respect users ldflags
authorConrad Kostecki <conikost@gentoo.org>
Mon, 11 May 2020 21:50:11 +0000 (23:50 +0200)
committerConrad Kostecki <conikost@gentoo.org>
Mon, 11 May 2020 21:53:52 +0000 (23:53 +0200)
Closes: https://bugs.gentoo.org/722374
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
app-misc/transfolio/transfolio-1.0.1-r1.ebuild [new file with mode: 0644]

diff --git a/app-misc/transfolio/transfolio-1.0.1-r1.ebuild b/app-misc/transfolio/transfolio-1.0.1-r1.ebuild
new file mode 100644 (file)
index 0000000..fb39bd2
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Enables data transfer between the PC and the Atari Portfolio"
+HOMEPAGE="http://leute.server.de/peichl/"
+SRC_URI="http://leute.server.de/peichl/transfolio.zip -> ${P}.zip"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+src_prepare() {
+       default
+
+       # Respect users CC, CFLAGS, LDFLAGS and disable striping
+       sed -e 's/cc/${CC}/' -e 's/-O2/${CFLAGS} ${LDFLAGS}/' -e '/strip/d' -i Makefile || die
+
+       tc-export CC
+}
+
+src_install() {
+       dobin transfolio
+
+       einstalldocs
+}