dev-python/Babel: Use distutils_enable_sphinx
authorMichał Górny <mgorny@gentoo.org>
Mon, 25 Nov 2019 12:24:40 +0000 (13:24 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 25 Nov 2019 12:34:59 +0000 (13:34 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/Babel/Babel-2.7.0.ebuild

index 94515713987a7e88b9832ed797d0bbb777906b48..42b0b5512da015a01036380360c3e2105ad0af5b 100644 (file)
@@ -15,37 +15,25 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="doc test"
+IUSE="test"
 RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
        dev-python/setuptools[${PYTHON_USEDEP}]"
 DEPEND="${DEPEND}
-       doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )
        test? ( dev-python/freezegun[${PYTHON_USEDEP}]
                dev-python/pytest[${PYTHON_USEDEP}] )"
 
-python_check_deps() {
-       use doc || return 0
-       has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
-}
+distutils_enable_sphinx docs
 
 python_prepare_all() {
        # Make the tests use implementation-specific datadir,
        # because they try to write in it.
        sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
                -i tests/messages/test_frontend.py || die
-       sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
        distutils-r1_python_prepare_all
 }
 
-python_compile_all() {
-       if use doc; then
-               emake -C docs html
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
 python_test() {
        local -x TZ=UTC