media-libs/libglvnd: Drop old versions
authorMatt Turner <mattst88@gentoo.org>
Thu, 5 Dec 2019 22:06:12 +0000 (17:06 -0500)
committerMatt Turner <mattst88@gentoo.org>
Thu, 5 Dec 2019 22:29:33 +0000 (17:29 -0500)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
media-libs/libglvnd/Manifest
media-libs/libglvnd/libglvnd-1.2.0-r1.ebuild [deleted file]

index c3ac0c352b135946bcddd34638ef443404cba0c2..2eca6f17a70309726bf030405017f559890a5037 100644 (file)
@@ -1,2 +1 @@
-DIST libglvnd-1.2.0.tar.gz 2030275 BLAKE2B b6b147f431ba9a177be9eada7af0e4ffc05c412e29f3a257746d74ff99078ecf87f7e66a97f7c1ce2779b3224bf3e7d1c4ab57c437074ae754e646c9275dae7f SHA512 f09a3ab3f1ba7397616cf2b0baf4385bd2127abb06817f8b383549cb21f36802be24a29598d7bfdd4c410b9ea95335b4ffc52529824dc88a719af52432c6b74c
 DIST libglvnd-1.3.0.tar.bz2 713781 BLAKE2B 15014038e8a0f14fc29892354b282535735af0f29e244e4826b945071deec151783fc042f3588add24c31f35a5c72c53bfb1090c109117466f8b8c805cc67356 SHA512 d573fc4a1114be9468afd6e035b3815111f9a7e7453bc2b127c93a1b8a01c7f20440ff8872fbae8fc93aab98862dac3224ceca7f28d02e93f3b9a641d1a248e3
diff --git a/media-libs/libglvnd/libglvnd-1.2.0-r1.ebuild b/media-libs/libglvnd/libglvnd-1.2.0-r1.ebuild
deleted file mode 100644 (file)
index 42b0789..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2018-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGIT_REPO_URI="https://github.com/NVIDIA/${PN}.git"
-
-if [[ ${PV} = 9999* ]]; then
-       GIT_ECLASS="git-r3"
-fi
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-inherit autotools ${GIT_ECLASS} multilib-minimal python-any-r1
-
-DESCRIPTION="The GL Vendor-Neutral Dispatch library"
-HOMEPAGE="https://github.com/NVIDIA/libglvnd"
-if [[ ${PV} = 9999* ]]; then
-       SRC_URI=""
-else
-       KEYWORDS="~amd64"
-       SRC_URI="https://github.com/NVIDIA/${PN}/releases/download/v${PV}/${P}.tar.gz"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="X"
-
-RDEPEND="
-       !media-libs/mesa[-libglvnd(-)]
-       !<media-libs/mesa-19.2.2
-       X? (
-               x11-libs/libX11[${MULTILIB_USEDEP}]
-               x11-libs/libXext[${MULTILIB_USEDEP}]
-       )"
-DEPEND="${PYTHON_DEPS}
-       ${RDEPEND}
-       X? ( x11-base/xorg-proto )"
-
-src_prepare() {
-       default
-       [[ $PV = 9999* ]] && eautoreconf
-}
-
-multilib_src_configure() {
-       myconf=(
-               $(use_enable X x11)
-               $(use_enable X glx)
-       )
-       ECONF_SOURCE=${S} econf "${myconf[@]}"
-}
-
-multilib_src_install() {
-       default
-       find "${D}" -name '*.la' -delete || die
-}
-
-multilib_src_test() {
-       emake check
-}