sys-libs/libcxx: Bump to 9.0.1 final
authorMichał Górny <mgorny@gentoo.org>
Sat, 21 Dec 2019 07:29:24 +0000 (08:29 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 21 Dec 2019 08:29:59 +0000 (09:29 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/libcxx/Manifest
sys-libs/libcxx/libcxx-9.0.1.ebuild [new file with mode: 0644]

index 881541a3b7c83cb28b6654aa8dae7626fa853afb..933947f5d2e5fa5d007cfbf75bf974422cde5237 100644 (file)
@@ -3,3 +3,4 @@ DIST libcxx-8.0.1.src.tar.xz 1739524 BLAKE2B 6e641cb6bda0de12c8408d3ab33f627389a
 DIST libcxx-9.0.0.src.tar.xz 1814388 BLAKE2B 59b8967706d1f85b1c0d2b9932bd637aae7118ae461e2b31e1d17c9a2ee2e02ea0ea8b344074a9fc4b430b5c742b8ad30c10a0c44e5290528fdecd7571352879 SHA512 cbaca724c4f3e3a270dfd53aac50cbb920190fe55486b164d52e73845819dd22afb10c23f5875da59d433fd5b96a0f153208746117309ac1267a38fa56f4818e
 DIST llvmorg-9.0.1-rc2.tar.gz 113203311 BLAKE2B 6e426060853e1587febedb75189444a1451236b713f800a4f3401c54318e48b0f5e0c484e9e4ef261faceed9b43b445a4153b061d4dadcc617047f9320b4f56a SHA512 fececd9365645920b9afdad1e94d5e10553ad4a39d84b3ac811b86014c395d51f7e4dabe54bb095a99481400c408bee3c9a2044168724d5e094e3258587a5d2c
 DIST llvmorg-9.0.1-rc3.tar.gz 113205740 BLAKE2B 3ca81e812833ecc2ac1bacfdeb86f54609ee125ba7390ce6af0113e949496149102360f35a9a0194dff93fb5cb6ade40a68382a03a7e55771a13198abb7ca9de SHA512 ea56a4ee57aacdd00a1d6551cdc768ecce3124a0eb6a9d09fe060bb147019a5119b2a9eaca576474be42e0296293daa923edd86dadb6759df0c2d7fc7a74f9f1
+DIST llvmorg-9.0.1.tar.gz 113193320 BLAKE2B b86e405f2b8e00436045fd409fe19cdde75c797b1192c62a22b5ec75e6b4dc8e874a0f33008dc31562445e4cbe53a992b6f48c684255a6a1ef261e595b8b161f SHA512 fa88beeaae94b6d0cd9b5ba38658d0ffed8004035d7d8a4f95c3d31a709b88b581ae9bd7761333c8e5375c44b8f6be01768b5a3be901163159d7e6c43b71da59
diff --git a/sys-libs/libcxx/libcxx-9.0.1.ebuild b/sys-libs/libcxx/libcxx-9.0.1.ebuild
new file mode 100644 (file)
index 0000000..41c96a8
--- /dev/null
@@ -0,0 +1,211 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit cmake-multilib llvm llvm.org multiprocessing python-any-r1 \
+       toolchain-funcs
+
+DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
+HOMEPAGE="https://libcxx.llvm.org/"
+LLVM_COMPONENTS=( libcxx )
+llvm.org_set_globals
+
+LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="elibc_glibc elibc_musl +libcxxabi libcxxrt +libunwind +static-libs test"
+REQUIRED_USE="libunwind? ( || ( libcxxabi libcxxrt ) )
+       ?? ( libcxxabi libcxxrt )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       libcxxabi? ( ~sys-libs/libcxxabi-${PV}[libunwind=,static-libs?,${MULTILIB_USEDEP}] )
+       libcxxrt? ( sys-libs/libcxxrt[libunwind=,static-libs?,${MULTILIB_USEDEP}] )
+       !libcxxabi? ( !libcxxrt? ( >=sys-devel/gcc-4.7:=[cxx] ) )"
+# llvm-6 for new lit options
+# clang-3.9.0 installs necessary target symlinks unconditionally
+# which removes the need for MULTILIB_USEDEP
+DEPEND="${RDEPEND}
+       >=sys-devel/llvm-6"
+BDEPEND="
+       test? ( >=sys-devel/clang-3.9.0
+               $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
+
+DOCS=( CREDITS.TXT )
+
+PATCHES=(
+       # Add link flag "-Wl,-z,defs" to avoid underlinking; this is needed in a
+       # out-of-tree build.
+       "${FILESDIR}/${PN}-3.9-cmake-link-flags.patch"
+)
+
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+python_check_deps() {
+       has_version "dev-python/lit[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+       llvm_pkg_setup
+       use test && python-any-r1_pkg_setup
+
+       if ! use libcxxabi && ! use libcxxrt && ! tc-is-gcc ; then
+               eerror "To build ${PN} against libsupc++, you have to use gcc. Other"
+               eerror "compilers are not supported. Please set CC=gcc and CXX=g++"
+               eerror "and try again."
+               die
+       fi
+       if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
+               eerror "${PN} needs to be built with gcc-4.7 or later (or other"
+               eerror "conformant compilers). Please use gcc-config to switch to"
+               eerror "gcc-4.7 or later version."
+               die
+       fi
+}
+
+test_compiler() {
+       $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c++ - \
+               <<<'int main() { return 0; }' &>/dev/null
+}
+
+src_configure() {
+       # note: we need to do this before multilib kicks in since it will
+       # alter the CHOST
+       local cxxabi cxxabi_incs
+       if use libcxxabi; then
+               cxxabi=libcxxabi
+               cxxabi_incs="${EPREFIX}/usr/include/libcxxabi"
+       elif use libcxxrt; then
+               cxxabi=libcxxrt
+               cxxabi_incs="${EPREFIX}/usr/include/libcxxrt"
+       else
+               local gcc_inc="${EPREFIX}/usr/lib/gcc/${CHOST}/$(gcc-fullversion)/include/g++-v$(gcc-major-version)"
+               cxxabi=libsupc++
+               cxxabi_incs="${gcc_inc};${gcc_inc}/${CHOST}"
+       fi
+
+       multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+       # we want -lgcc_s for unwinder, and for compiler runtime when using
+       # gcc, clang with gcc runtime (or any unknown compiler)
+       local extra_libs=() want_gcc_s=ON want_compiler_rt=OFF
+       if use libunwind; then
+               # work-around missing -lunwind upstream
+               extra_libs+=( -lunwind )
+               # if we're using libunwind and clang with compiler-rt, we want
+               # to link to compiler-rt instead of -lgcc_s
+               if tc-is-clang; then
+                       local compiler_rt=$($(tc-getCC) ${CFLAGS} ${CPPFLAGS} \
+                          ${LDFLAGS} -print-libgcc-file-name)
+                       if [[ ${compiler_rt} == *libclang_rt* ]]; then
+                               want_gcc_s=OFF
+                               want_compiler_rt=ON
+                               extra_libs+=( "${compiler_rt}" )
+                       fi
+               fi
+       fi
+
+       # bootstrap: cmake is unhappy if compiler can't link to stdlib
+       local nolib_flags=( -nodefaultlibs -lc )
+       if ! test_compiler; then
+               if test_compiler "${nolib_flags[@]}"; then
+                       local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
+                       ewarn "${CXX} seems to lack runtime, trying with ${nolib_flags[*]}"
+               fi
+       fi
+
+       local libdir=$(get_libdir)
+       local mycmakeargs=(
+               -DLIBCXX_LIBDIR_SUFFIX=${libdir#lib}
+               -DLIBCXX_ENABLE_SHARED=ON
+               -DLIBCXX_ENABLE_STATIC=$(usex static-libs)
+               -DLIBCXX_CXX_ABI=${cxxabi}
+               -DLIBCXX_CXX_ABI_INCLUDE_PATHS=${cxxabi_incs}
+               # we're using our own mechanism for generating linker scripts
+               -DLIBCXX_ENABLE_ABI_LINKER_SCRIPT=OFF
+               -DLIBCXX_HAS_MUSL_LIBC=$(usex elibc_musl)
+               -DLIBCXX_HAS_GCC_S_LIB=${want_gcc_s}
+               -DLIBCXX_INCLUDE_TESTS=$(usex test)
+               -DLIBCXX_USE_COMPILER_RT=${want_compiler_rt}
+               -DCMAKE_SHARED_LINKER_FLAGS="${extra_libs[*]} ${LDFLAGS}"
+       )
+
+       if use test; then
+               local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
+               local jobs=${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}
+
+               [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
+
+               mycmakeargs+=(
+                       -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
+                       -DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
+               )
+       fi
+       cmake-utils_src_configure
+}
+
+multilib_src_test() {
+       local -x LIT_PRESERVES_TMP=1
+       cmake-utils_src_make check-libcxx
+}
+
+# Usage: deps
+gen_ldscript() {
+       local output_format
+       output_format=$($(tc-getCC) ${CFLAGS} ${LDFLAGS} -Wl,--verbose 2>&1 | sed -n 's/^OUTPUT_FORMAT("\([^"]*\)",.*/\1/p')
+       [[ -n ${output_format} ]] && output_format="OUTPUT_FORMAT ( ${output_format} )"
+
+       cat <<-END_LDSCRIPT
+/* GNU ld script
+   Include missing dependencies
+*/
+${output_format}
+GROUP ( $@ )
+END_LDSCRIPT
+}
+
+gen_static_ldscript() {
+       local libdir=$(get_libdir)
+       local cxxabi_lib=$(usex libcxxabi "libc++abi.a" "$(usex libcxxrt "libcxxrt.a" "libsupc++.a")")
+
+       # Move it first.
+       mv "${ED}/usr/${libdir}/libc++.a" "${ED}/usr/${libdir}/libc++_static.a" || die
+       # Generate libc++.a ldscript for inclusion of its dependencies so that
+       # clang++ -stdlib=libc++ -static works out of the box.
+       local deps="libc++_static.a ${cxxabi_lib} $(usex libunwind libunwind.a libgcc_eh.a)"
+       # On Linux/glibc it does not link without libpthread or libdl. It is
+       # fine on FreeBSD.
+       use elibc_glibc && deps+=" libpthread.a libdl.a"
+
+       gen_ldscript "${deps}" > "${ED}/usr/${libdir}/libc++.a" || die
+}
+
+gen_shared_ldscript() {
+       local libdir=$(get_libdir)
+       # libsupc++ doesn't have a shared version
+       local cxxabi_lib=$(usex libcxxabi "libc++abi.so" "$(usex libcxxrt "libcxxrt.so" "libsupc++.a")")
+
+       mv "${ED}/usr/${libdir}/libc++.so" "${ED}/usr/${libdir}/libc++_shared.so" || die
+       local deps="libc++_shared.so ${cxxabi_lib} $(usex libunwind libunwind.so libgcc_s.so)"
+
+       gen_ldscript "${deps}" > "${ED}/usr/${libdir}/libc++.so" || die
+}
+
+multilib_src_install() {
+       cmake-utils_src_install
+       gen_shared_ldscript
+       use static-libs && gen_static_ldscript
+}
+
+pkg_postinst() {
+       elog "This package (${PN}) is mainly intended as a replacement for the C++"
+       elog "standard library when using clang."
+       elog "To use it, instead of libstdc++, use:"
+       elog "    clang++ -stdlib=libc++"
+       elog "to compile your C++ programs."
+}