kde-frameworks/kxmlgui: revision bump to add Qt subslot operator
authorMichael Palimaka <kensington@gentoo.org>
Sun, 19 Jun 2016 15:08:07 +0000 (01:08 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Sun, 19 Jun 2016 15:08:19 +0000 (01:08 +1000)
Package-Manager: portage-2.3.0_rc1

kde-frameworks/kxmlgui/kxmlgui-5.23.0-r1.ebuild [new file with mode: 0644]

diff --git a/kde-frameworks/kxmlgui/kxmlgui-5.23.0-r1.ebuild b/kde-frameworks/kxmlgui/kxmlgui-5.23.0-r1.ebuild
new file mode 100644 (file)
index 0000000..9f4e327
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for managing menu and toolbar actions in an abstract way"
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="LGPL-2+"
+IUSE="attica"
+
+# drop qtgui subslot operator when QT_MINIMAL >= 5.6.0
+RDEPEND="
+       $(add_frameworks_dep kconfig)
+       $(add_frameworks_dep kconfigwidgets)
+       $(add_frameworks_dep kcoreaddons)
+       $(add_frameworks_dep kglobalaccel)
+       $(add_frameworks_dep ki18n)
+       $(add_frameworks_dep kiconthemes)
+       $(add_frameworks_dep kitemviews)
+       $(add_frameworks_dep ktextwidgets)
+       $(add_frameworks_dep kwidgetsaddons)
+       $(add_frameworks_dep kwindowsystem)
+       $(add_qt_dep qtdbus)
+       $(add_qt_dep qtgui '' '' '5=')
+       $(add_qt_dep qtnetwork 'ssl')
+       $(add_qt_dep qtprintsupport)
+       $(add_qt_dep qtwidgets)
+       $(add_qt_dep qtxml)
+       attica? ( $(add_frameworks_dep attica) )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+       local mycmakeargs=(
+               $(cmake-utils_use_find_package attica KF5Attica)
+       )
+
+       kde5_src_configure
+}