net-proxy/tayga: fix conf.d and init.d insertions.
authorBenda Xu <heroxbd@gentoo.org>
Sat, 19 Oct 2019 15:09:06 +0000 (23:09 +0800)
committerBenda Xu <heroxbd@gentoo.org>
Sat, 19 Oct 2019 15:10:44 +0000 (23:10 +0800)
Closes: https://bugs.gentoo.org/688364
Package-Manager: Portage-2.3.73, Repoman-2.3.17
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
net-proxy/tayga/files/tayga.initd
net-proxy/tayga/tayga-0.9.2-r3.ebuild

index a0ad1dd301515b3159824b3bc0f9b378f4ef0a02..f184a29b336c26681b1fcfc43c5aa22f4b638aac 100644 (file)
@@ -4,7 +4,7 @@
 #
 
 description='tayga NAT64 gateway'
-pidfile=${pidfile:=/var/run/tayga.pid}
+pidfile=${pidfile:=/run/tayga.pid}
 user=${user:=nobody}
 group=${group:=nogroup}
 datadir=${datadir:=/var/db/tayga}
index 4d84b05240f6d023a12643b7885177df14b7e7e5..f4c824c4e7b0e19c9bd21327b83cd089d3affd3d 100644 (file)
@@ -31,6 +31,7 @@ src_prepare() {
 }
 
 src_install() {
-       newconfd "${FILESDIR}"/tayga.confd
-       newinitd "${FILESDIR}"/tayga.initd
+       default
+       newconfd "${FILESDIR}"/tayga.confd ${PN}
+       newinitd "${FILESDIR}"/tayga.initd ${PN}
 }