Initial import
authorSebastien Fabbro <bicatali@gentoo.org>
Wed, 4 Jan 2012 21:49:17 +0000 (21:49 +0000)
committerSebastien Fabbro <bicatali@gentoo.org>
Wed, 4 Jan 2012 21:49:17 +0000 (21:49 +0000)
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64

dev-python/polygon/ChangeLog [new file with mode: 0644]
dev-python/polygon/Manifest [new file with mode: 0644]
dev-python/polygon/metadata.xml [new file with mode: 0644]
dev-python/polygon/polygon-2.0.4.ebuild [new file with mode: 0644]
dev-python/polygon/polygon-3.0.4.ebuild [new file with mode: 0644]

diff --git a/dev-python/polygon/ChangeLog b/dev-python/polygon/ChangeLog
new file mode 100644 (file)
index 0000000..b10065a
--- /dev/null
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/polygon
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/ChangeLog,v 1.1 2012/01/04 21:49:17 bicatali Exp $
+
+*polygon-3.0.4 (04 Jan 2012)
+*polygon-2.0.4 (04 Jan 2012)
+
+  04 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +polygon-2.0.4.ebuild,
+  +polygon-3.0.4.ebuild, +metadata.xml:
+  Initial import
+
diff --git a/dev-python/polygon/Manifest b/dev-python/polygon/Manifest
new file mode 100644 (file)
index 0000000..80dcf09
--- /dev/null
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST Polygon-2.0.4.zip 73544 RMD160 dfb26325998f3e8b44ac36f6ef2c0be30b8d9fd9 SHA1 aa734572c911c0ddb4b39d1bf21f8ecbfa3685c8 SHA256 a9a85d81cc9faabba398001b1e9d32444e98147ac6e31cbdc5ef512c4f7c43dd
+DIST Polygon-3.0.4a-src.zip 163024 RMD160 be1fca82612a7f70d0da70a217b1b7ec4c9a1c9a SHA1 5030b2c687b2d5b70437d6d5fc341fac818c99dd SHA256 2ebef747544660a17a4aefc5a5a8429b6c64af8e0044130f98ed241b48e8fd9d
+EBUILD polygon-2.0.4.ebuild 859 RMD160 19b4f0428eca303d1c789dd3dd95b704d2d599eb SHA1 84764e6be5f0dbfdecee332e33f0497a7d20823f SHA256 abd860c44fe7e328d66e408e72a13e28cc5384af830de3de10a4b8985f249f96
+EBUILD polygon-3.0.4.ebuild 863 RMD160 2efdc2bc0177b9d66dd2c9df671937ee9a3e5229 SHA1 a9f1fac08883491df266b8f1c4bbc48f9da398be SHA256 48d7be5c57cc4d8222ea084e4c6efacc70304c68cf5ced433276ac61c6383a13
+MISC ChangeLog 406 RMD160 ea8a19bfa20875e4293f2860fd5dce2ff0684c6e SHA1 a8299cb4355736ad287976c1fb68f0f7bb98d91c SHA256 59dfea5d79b570f5c5df4f8996156da0151effae155def694d4915cd1a536073
+MISC metadata.xml 417 RMD160 8adacb5edc99072df7ec8f3efa4e8033f8cfbe05 SHA1 3bb4dfcd22e5270bd6f151bea79f1d13a1692345 SHA256 6bcbb5801c689f8b955aa4732e134863f86982df231864b8af04aa3503ae12d2
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iEYEARECAAYFAk8EyWgACgkQ1ycZbhPLE2B0pQCfaGKtX98bxpxbnlECLtlScpvW
+7bMAniqhyK0pdOvbwrXrXYSTB7a8Qx8w
+=9q7A
+-----END PGP SIGNATURE-----
diff --git a/dev-python/polygon/metadata.xml b/dev-python/polygon/metadata.xml
new file mode 100644 (file)
index 0000000..9754f81
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription lang="en">
+  Polygon is a python package that handles polygonal shapes in 2D. It contains 
+  Python bindings for gpc, the General Polygon Clipping Library by 
+  Alan Murta and some extensions written in C and pure Python.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/polygon/polygon-2.0.4.ebuild b/dev-python/polygon/polygon-2.0.4.ebuild
new file mode 100644 (file)
index 0000000..4dd99fd
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/polygon-2.0.4.ebuild,v 1.1 2012/01/04 21:49:17 bicatali Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Python package to handle polygonal shapes in 2D"
+HOMEPAGE="http://www.j-raedler.de/projects/polygon/"
+SRC_URI="https://github.com/downloads/jraedler/Polygon2/Polygon-${PV}.zip"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       app-arch/unzip"
+
+S="${WORKDIR}/Polygon-${PV}"
+
+src_test() {
+       testing() {
+               PYTHONPATH="$(dir -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" test/Test.py
+       }
+       python_execute_function testing
+}
+
+src_install() {
+       distutils_src_install
+       dodoc HISTORY doc/Polygon.txt
+}
diff --git a/dev-python/polygon/polygon-3.0.4.ebuild b/dev-python/polygon/polygon-3.0.4.ebuild
new file mode 100644 (file)
index 0000000..ca5cdaf
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/polygon-3.0.4.ebuild,v 1.1 2012/01/04 21:49:17 bicatali Exp $
+
+EAPI=3
+PYTHON_DEPEND="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.*"
+
+inherit distutils
+
+DESCRIPTION="Python package to handle polygonal shapes in 2D"
+HOMEPAGE="http://www.j-raedler.de/projects/polygon"
+SRC_URI="https://github.com/downloads/jraedler/Polygon3/Polygon-${PV}a-src.zip"
+
+LICENSE="LGPL-2"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       app-arch/unzip"
+
+S="${WORKDIR}/Polygon-${PV}"
+
+src_test() {
+       testing() {
+               PYTHONPATH="$(dir -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" test/Test.py
+       }
+       python_execute_function testing
+}
+
+src_install() {
+       distutils_src_install
+       dodoc HISTORY doc/Polygon.txt
+}