games-rpg/pcgen: remove deprecated games eclass
authorAustin English <wizardedit@gentoo.org>
Sat, 15 Oct 2016 11:06:43 +0000 (06:06 -0500)
committerAustin English <wizardedit@gentoo.org>
Sat, 15 Oct 2016 11:08:15 +0000 (06:08 -0500)
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0

games-rpg/pcgen/pcgen-6.04.01-r1.ebuild [new file with mode: 0644]

diff --git a/games-rpg/pcgen/pcgen-6.04.01-r1.ebuild b/games-rpg/pcgen/pcgen-6.04.01-r1.ebuild
new file mode 100644 (file)
index 0000000..f019053
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2-utils
+
+DESCRIPTION="D&D character generator"
+HOMEPAGE="http://pcgen.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pcgen/${P}-full.zip"
+
+LICENSE="LGPL-2.1 OGL-1.0a"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+       default
+
+       rm -vf *.bat || die
+       sed "/dirname/ c\cd \"\/usr\/share\/${PN}\"" pcgen.sh > "${T}"/${PN} || die
+}
+
+src_install() {
+       dobin "${T}"/${PN}
+       insinto /usr/share/${PN}
+       doins -r *
+       newicon -s 128 system/sponsors/pcgen/pcgen_128x128.png ${PN}.png
+       make_desktop_entry ${PN} PCGen
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}