dev-python/sphinxcontrib-cheeseshop: fix for bug #623852 and add namespace
authorSébastien Fabbro <bicatali@gentoo.org>
Tue, 1 Aug 2017 22:25:12 +0000 (22:25 +0000)
committerSébastien Fabbro <bicatali@gentoo.org>
Wed, 2 Aug 2017 04:06:23 +0000 (04:06 +0000)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r2.ebuild [new file with mode: 0644]

diff --git a/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r2.ebuild b/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r2.ebuild
new file mode 100644 (file)
index 0000000..0dad495
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension cheeseshop"
+HOMEPAGE="https://bitbucket.org/birkenfeld/sphinx-contrib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/sphinx-1.0[${PYTHON_USEDEP}]
+       dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       sed \
+               -e '5s/file/open/' \
+               -i setup.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       find "${ED}" -name '*.pth' -delete || die
+}