dev-ruby/globalid: fix tests
authorHans de Graaff <graaff@gentoo.org>
Sun, 3 May 2020 08:15:29 +0000 (10:15 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 3 May 2020 08:15:52 +0000 (10:15 +0200)
Add missing require for Forwardable. This probably got dropped
in one of the dependencies at some point.

Bug: https://bugs.gentoo.org/720408
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/globalid/globalid-0.4.2.ebuild

index 9d61ff1f8a1450c364ae146cd8c909560f6a0b69..1d8455b2ab543a84af84fc4ffb1120b964d69aed 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -23,4 +23,6 @@ ruby_add_rdepend ">=dev-ruby/activesupport-4.2.0:*"
 
 all_ruby_prepare() {
        rm -f Gemfile.lock || die
+
+       sed -i -e '2irequire "forwardable"' test/helper.rb || die
 }