app-shells/localshell: EAPI 5 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Sat, 29 Aug 2015 22:34:11 +0000 (22:34 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Sat, 29 Aug 2015 22:34:11 +0000 (22:34 +0000)
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
app-shells/localshell/localshell-1.3.4-r1.ebuild [new file with mode: 0644]

diff --git a/app-shells/localshell/localshell-1.3.4-r1.ebuild b/app-shells/localshell/localshell-1.3.4-r1.ebuild
new file mode 100644 (file)
index 0000000..d2b134f
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base eutils
+
+DESCRIPTION="Localshell allows per-user/group local control of shell execution"
+HOMEPAGE="http://git.orbis-terrarum.net/?p=infrastructure/localshellc.git;a=summary"
+SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_configure() {
+       # this is a shell, it needs to be in /bin
+       econf --bindir=/bin --sysconfdir=/etc
+}
+
+src_install() {
+       emake install DESTDIR="${D}" || die "emake install failed"
+       rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL}
+}
+
+pkg_postinst() {
+       elog "Remember to add /bin/localshell to /etc/shells and create"
+       elog "/etc/localshell.conf based on the included configuration examples"
+}