dev-cpp/libassa: Modernise to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Wed, 1 Mar 2017 18:41:38 +0000 (19:41 +0100)
committerDavid Seifert <soap@gentoo.org>
Wed, 1 Mar 2017 18:41:38 +0000 (19:41 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-cpp/libassa/libassa-3.5.1-r2.ebuild [moved from dev-cpp/libassa/libassa-3.5.1-r1.ebuild with 63% similarity]

similarity index 63%
rename from dev-cpp/libassa/libassa-3.5.1-r1.ebuild
rename to dev-cpp/libassa/libassa-3.5.1-r2.ebuild
index 81f5fb6d146a86bb400596f53e9960a7d8d1cabe..8d46aa4035ef632f906422dc12385a08e0ea2a98 100644 (file)
@@ -1,8 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-inherit eutils
+EAPI=6
 
 DESCRIPTION="A networking library based on Adaptive Communication Patterns"
 HOMEPAGE="http://libassa.sourceforge.net/"
@@ -17,12 +16,10 @@ RDEPEND="net-libs/libtirpc"
 DEPEND="${RDEPEND}
        doc? ( app-doc/doxygen )"
 
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-3.5.0-fix-tests.patch \
-               "${FILESDIR}"/${P}-gcc47.patch
-}
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.5.0-fix-tests.patch
+       "${FILESDIR}"/${PN}-3.5.1-gcc47.patch
+)
 
 src_configure() {
        econf \
@@ -32,5 +29,6 @@ src_configure() {
 
 src_install() {
        default
-       find "${ED}" -name "*.la" -exec rm -rf {} + || die "failed to delete .la files"
+
+       find "${D}" -name '*.la' -delete || die
 }