dev-python/pytest-capturelog: eapi7 + py3_7
authorAlexey Shvetsov <alexxy@gentoo.org>
Fri, 9 Nov 2018 13:23:54 +0000 (16:23 +0300)
committerAlexey Shvetsov <alexxy@gentoo.org>
Fri, 9 Nov 2018 13:42:18 +0000 (16:42 +0300)
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
dev-python/pytest-capturelog/pytest-capturelog-0.7-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pytest-capturelog/pytest-capturelog-0.7-r1.ebuild b/dev-python/pytest-capturelog/pytest-capturelog-0.7-r1.ebuild
new file mode 100644 (file)
index 0000000..e9756cc
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin to capture log messages"
+HOMEPAGE="https://bitbucket.org/memedough/pytest-capturelog/overview"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+COMMON_DEPEND="dev-python/py[${PYTHON_USEDEP}]"
+DEPEND="${COMMON_DEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="${COMMON_DEPEND}
+       !dev-python/pytest-catchlog"
+
+# Not included
+# https://bitbucket.org/memedough/pytest-capturelog/issues/5
+RESTRICT=test
+
+python_test() {
+       PYTEST_PLUGINS=${PN/-/_} py.test -v -v test_capturelog.py || die
+}