dev-python/oslo-cache: fix stale cache on network partition
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 7 May 2019 01:53:47 +0000 (20:53 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 7 May 2019 01:54:03 +0000 (20:54 -0500)
Bug: https://bugs.gentoo.org/681012
Package-Manager: Portage-2.3.62, Repoman-2.3.12
RepoMan-Options: --force
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/oslo-cache/Manifest
dev-python/oslo-cache/oslo-cache-1.30.3-r1.ebuild [moved from dev-python/oslo-cache/oslo-cache-1.30.3.ebuild with 87% similarity]
dev-python/oslo-cache/oslo-cache-1.33.2-r1.ebuild [moved from dev-python/oslo-cache/oslo-cache-1.33.2.ebuild with 87% similarity]

index 55c1a59188116f0d65c6ad8488410a614429671c..c9997096ffda2de39c100e2ce2afb4b34c74e15b 100644 (file)
@@ -1,2 +1,3 @@
+DIST bug-681012.patch 4751 BLAKE2B 50c95275ec06522292bcbc7833af63bff98dcc112b2c2f742c0807d02bf090cfdd70fdeed433149ca3f27b7b5d356d7bd321c145aa8fb212ffa6e77b42da976f SHA512 f7ebbe5fbdbb570fbadc7d840c11fba49a9bc13e04626df053aae3da5668641f095a48d89229a7fd2b894d86c58f14699822e16923f183c099792dcde0777051
 DIST oslo-cache-1.30.3.tar.gz 53116 BLAKE2B 0b63f828f61dd82b69efe7a6e345974c56b2e980d88f159dd7c3ba5484cd1e8f78a393a7f73a6f2152db1c30178a054e2f20d753a286a0cd8f7d83af7f623bf2 SHA512 3ab9842cd388a846fe9004b97364057245936b9af185ba0f68e6d6bcc750dd957eb873d45e686cddeec94fda6872b72e4549c71ebc9e1de4755504c2a138b85c
 DIST oslo-cache-1.33.2.tar.gz 55778 BLAKE2B e75fea8b669d30efdf72bd565deb560dfe2c1627e4bca74ffbce923341e5663d641ae44b144e070e4af7587c08e911a4b025ffd0ca1bbc39dfc4ed3266cde1c8 SHA512 8111ba9f62724ff6ee64750a88807e40a38252273669c96b86dedd0e36f2d1661f54fd55bc462ffa577e95771d08965ad6be208224d442306d869db2d155da91
similarity index 87%
rename from dev-python/oslo-cache/oslo-cache-1.30.3.ebuild
rename to dev-python/oslo-cache/oslo-cache-1.30.3-r1.ebuild
index a518852976229519824bcbb5585f4c873f4afe91..a185fd0340566017b2d133408cd688da4cfe3d38 100644 (file)
@@ -11,7 +11,8 @@ MY_PN=${PN/-/.}
 
 DESCRIPTION="Oslo Caching around dogpile.cache"
 HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
+       https://dev.gentoo.org/~prometheanfire/dist/openstack/keystone/patches/bug-681012.patch"
 
 LICENSE="Apache-2.0"
 SLOT="0"
@@ -33,6 +34,10 @@ RDEPEND="
        >=dev-python/oslo-utils-3.31.0[${PYTHON_USEDEP}]
 "
 
+PATCHES=(
+       "${DISTDIR}/bug-681012.patch"
+)
+
 python_prepare_all() {
        sed -i '/^hacking/d' test-requirements.txt || die
        distutils-r1_python_prepare_all
similarity index 87%
rename from dev-python/oslo-cache/oslo-cache-1.33.2.ebuild
rename to dev-python/oslo-cache/oslo-cache-1.33.2-r1.ebuild
index 0292bb44c6a01107509634ab9102d36e69f12468..1507ee6fb2e65301aa10ece04a6463c0a49676fe 100644 (file)
@@ -10,7 +10,9 @@ MY_PN=${PN/-/.}
 
 DESCRIPTION="Oslo Caching around dogpile.cache"
 HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
+       https://dev.gentoo.org/~prometheanfire/dist/openstack/keystone/patches/bug-681012.patch"
+
 S="${WORKDIR}/${MY_PN}-${PV}"
 
 LICENSE="Apache-2.0"
@@ -33,6 +35,10 @@ RDEPEND="
        >=dev-python/oslo-utils-3.31.0[${PYTHON_USEDEP}]
 "
 
+PATCHES=(
+       "${DISTDIR}/bug-681012.patch"
+)
+
 python_prepare_all() {
        sed -i '/^hacking/d' test-requirements.txt || die
        distutils-r1_python_prepare_all