media-sound/mp3splt-gtk: Drop USE audacious
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Dec 2019 10:52:39 +0000 (11:52 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Dec 2019 12:04:03 +0000 (13:04 +0100)
Closes: https://bugs.gentoo.org/521176
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-sound/mp3splt-gtk/metadata.xml
media-sound/mp3splt-gtk/mp3splt-gtk-0.9.2-r1.ebuild

index 19ed72cab9b799292377e3c48ada4c77d15165fb..fa7e71f336a3946994a8caaae82ab8326a050905 100644 (file)
@@ -5,9 +5,6 @@
                <email>sound@gentoo.org</email>
                <name>Gentoo Sound project</name>
        </maintainer>
-       <use>
-               <flag name="audacious">Include <pkg>media-sound/audacious</pkg> support</flag>
-       </use>
        <upstream>
                <remote-id type="sourceforge">mp3splt</remote-id>
        </upstream>
index 741682ebf20c0821b13b968b4a6c7c82981401ed..d0f02f52dc940b3cca46ab414ef20adaeff66320 100644 (file)
@@ -2,7 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit versionator autotools multilib
+
+inherit versionator autotools
 
 DESCRIPTION="a GTK+ based utility to split mp3 and ogg files without decoding"
 HOMEPAGE="http://mp3splt.sourceforge.net"
@@ -11,13 +12,12 @@ SRC_URI="mirror://sourceforge/mp3splt/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ~hppa ~ppc ~ppc64 sparc x86"
-IUSE="audacious doc gstreamer nls"
+IUSE="doc gstreamer nls"
 
 RDEPEND="
        >=media-libs/libmp3splt-0.9.2
        x11-libs/gtk+:3
-       audacious? ( >=media-sound/audacious-3.0 )
-       !audacious? ( dev-libs/dbus-glib )
+       dev-libs/dbus-glib
        gstreamer? (
                media-libs/gstreamer:1.0
                media-plugins/gst-plugins-meta:1.0[mp3] )
@@ -29,13 +29,6 @@ DEPEND="${RDEPEND}
 
 src_prepare() {
        default
-
-       if use audacious; then
-               sed -i \
-                       -e 's:@AUDACIOUS_LIBS@:-laudclient &:' \
-                       src/Makefile.am || die
-       fi
-
        eautoreconf
 }
 
@@ -43,10 +36,10 @@ src_configure() {
        local myconf
 
        use nls || myconf+=" --disable-nls"
-       use audacious || myconf+=" --disable-audacious"
        use gstreamer || myconf+=" --disable-gstreamer"
 
        econf \
+               --disable-audacious \
                --disable-gnome \
                $(use_enable doc doxygen_doc) \
                --disable-cutter \