dev-python/texttable: bump to 1.6.2
authorJoonas Niilola <juippis@gmail.com>
Fri, 12 Jul 2019 07:45:30 +0000 (10:45 +0300)
committerMichał Górny <mgorny@gentoo.org>
Tue, 16 Jul 2019 15:37:45 +0000 (17:37 +0200)
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Joonas Niilola <juippis@gmail.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/texttable/Manifest
dev-python/texttable/texttable-1.6.2.ebuild [new file with mode: 0644]

index 1e6a75dd7b90e8d37d5fe414d2ff28d5be1fc110..c2bdce6479414c62cc7dc444064954099a5d2cf1 100644 (file)
@@ -1,2 +1,3 @@
 DIST texttable-0.9.1.tar.gz 11074 BLAKE2B 465738a7b980f2a216d63b268044c1a1b8c0deb986fd398f0ba0ae30ab84020ac6f179b5314a2071592c38443f9cb86387b9ed573342533af9e825000472ebe5 SHA512 7ec37336ef4b253879d0232dcdb4500cad33ecce1067dd7ea26c221dc2c003ee56360bdbd1dd1e00133301c51c67fb2fe9b1703628804a65f2a6ab8a1e830e50
 DIST texttable-1.6.1.tar.gz 11185 BLAKE2B d3fd85de8b6fa14ec6c520c0c0049ee043285fecaf7d31fbc1f361e0c9a27b66a75caf8aa0f85109523143f36ba2da47818ce91c4946c0b4d5391a0a4c5d9028 SHA512 72d4bb5c4f03b1f9dbfc4b1e375ad754e92610f71e65c7e9a0b7bdc88b3753254b143aa607570d49cfca56a3cf889a819e12ea184fdf34594f1f5d118de3c12c
+DIST texttable-1.6.2.tar.gz 11450 BLAKE2B 8090914b20a93283ea3d533a8120d4d2c5f058a0e79550b29d4b9fa740db5e309d84a7983fb6665149e3624ba7039b67ff6a553b180b915a348e5b53e793d5cd SHA512 e59275c64813bd00fa5172c43491820122b6045e1a416c917576cbf595c1ec24d146e571708379f4b32775bda904f16ced0e9e15ab7b2dde78a214f26a1c4de6
diff --git a/dev-python/texttable/texttable-1.6.2.ebuild b/dev-python/texttable/texttable-1.6.2.ebuild
new file mode 100644 (file)
index 0000000..7b84c8a
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for creating simple ASCII tables"
+HOMEPAGE="https://github.com/foutaise/texttable https://pypi.org/project/texttable/"
+SRC_URI="https://github.com/foutaise/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cjk test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/wcwidth[${PYTHON_USEDEP}]
+               cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )
+       )
+"
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]
+       cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )"
+
+python_test() {
+       pytest -vv tests.py || die
+}