dev-ros/gazebo_ros_control: remove old
authorAlexis Ballier <aballier@gentoo.org>
Tue, 26 Jul 2016 08:59:18 +0000 (10:59 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 26 Jul 2016 09:18:30 +0000 (11:18 +0200)
Package-Manager: portage-2.3.0

dev-ros/gazebo_ros_control/Manifest
dev-ros/gazebo_ros_control/files/gazebo7.patch [deleted file]
dev-ros/gazebo_ros_control/gazebo_ros_control-2.5.1.ebuild [deleted file]
dev-ros/gazebo_ros_control/gazebo_ros_control-2.5.2.ebuild [deleted file]
dev-ros/gazebo_ros_control/gazebo_ros_control-2.5.3.ebuild [deleted file]
dev-ros/gazebo_ros_control/gazebo_ros_control-2.5.6.ebuild [deleted file]

index 85e31aa7c7d60126b697c0d9e0addd3d247dd34a..cf8a4de67534e8c80f07801cf8f2fec3ba1198dc 100644 (file)
@@ -1,5 +1 @@
-DIST gazebo_ros_pkgs-2.5.1.tar.gz 1812295 SHA256 1d78839d174790db400466b4b165a79fea50177a3fbe59291539b8bdc1876d4e SHA512 2e0faaa770abe9ff2b41d176c7a3dadaf8749f32c924ba6018b3d7dabf0fe2a1e4ffd24c840c777229a4941e7f4522bf2287288619e2c819d4fb3c10fa431c9d WHIRLPOOL 09b0c5038b21a6cfc355fed8d8d2981cb845c8d209cb89112fb6daf1694b735dd68096ca7e2f255fdc2e8ba435080df186057344c81c2ac247c28d64019dbe32
-DIST gazebo_ros_pkgs-2.5.2.tar.gz 1815044 SHA256 849c541412b7312d3455827ccf386246b5bbc4d674e76ed0e9e08032026a929b SHA512 1f8b7034520712606e8389526115f0bae4084cbfdd1b5834f5c00233ae2864260cbb591512228f1519642fde860366a7b4f9602d5374817ca084494668b76bd4 WHIRLPOOL 13283cda29a4da4efb366d3074b9a55ca61b5c9e4a27b3cb467210405ed82334a849a3353f652bc6333e86e845f5845437ebaa23942a027a288fcd831fc77525
-DIST gazebo_ros_pkgs-2.5.3.tar.gz 1816954 SHA256 5c30ea914b624fb0bf1ca8bda869b9c10ce8336114e629ef19ad075320f4fca4 SHA512 9c045c0fa5be33c37017fc6abe5f307e97c8c9190a4c602e66f3dcc6435854b8c1bd863e26fc1e480c7be0bca381889677f140bd8948abe55cb468c19c636039 WHIRLPOOL 35d07adce0ab4f1accd4acf1fc11f2309776f8870abc2ec69422c60962acbb4cb1157c4e81e40517202b2573ffc6daa2a49f129c2b2c4117a886f77c433fcddd
-DIST gazebo_ros_pkgs-2.5.6.tar.gz 1821635 SHA256 ff8da02dd8c58a92deddcff9bf67c3d9583cb0fac0e6435774989f7451c939c8 SHA512 7c815de70d5e3a27f4796de2d0cebbbbde85dc55f90da3d2db6ea650a4c82bd333f3f1d5aaf3a6d9d6d1101fd54bf589f97d02c6d89ba5e78c72d79a90e0aa10 WHIRLPOOL 17b9caa8a5aa17284d6a0409064b0ec8300877f2a1ec701707e787d079a612b80d0a7758822e99d64a5d125bd32066fe8b2809fbace4facfa5490af4a8d9ac32
 DIST gazebo_ros_pkgs-2.5.7.tar.gz 1821656 SHA256 6a40c129d4b4d6c7c5d4608aac7314b84f815a4416cd905d71b2b98067c2aaa7 SHA512 13790eaa50d6a6b1be26236ce3dd118f6d09c1096b7c95fffbad99fe70d59546b8169597eda5fa774cce37c5b3f46ca61b3c66a8520b675fb8c020e36f002d94 WHIRLPOOL b94be63a019d4bd9fa175f6c8c24f96c2e034ebfdf9b4f96aad6e71476409cb57453c895d2bb14aa50ba1410fb89302147c0677c055544ef826b28425e0a1046
diff --git a/dev-ros/gazebo_ros_control/files/gazebo7.patch b/dev-ros/gazebo_ros_control/files/gazebo7.patch
deleted file mode 100644 (file)
index 190756d..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-commit b5303e692bb5dd2e4f4fc7932c7ec2c7e0b2e907
-Author: Steven Peters <scpeters@osrfoundation.org>
-Date:   Tue Apr 14 18:10:36 2015 -0700
-
-    Use Joint::SetParam for joint velocity motors
-    
-    Before gazebo5, Joint::SetVelocity and SetMaxForce
-    were used to set joint velocity motors.
-    The API has changed in gazebo5, to use Joint::SetParam
-    instead.
-    The functionality is still available through the SetParam API.
-    
-    cherry-picked from indigo-devel
-    
-    Add ifdefs to fix build with gazebo2
-    
-    It was broken by #315.
-    Fixes #321.
-
-diff --git a/gazebo_ros_control/src/default_robot_hw_sim.cpp b/gazebo_ros_control/src/default_robot_hw_sim.cpp
-index 249c8d3..1d9418d 100644
---- a/gazebo_ros_control/src/default_robot_hw_sim.cpp
-+++ b/gazebo_ros_control/src/default_robot_hw_sim.cpp
-@@ -199,7 +199,7 @@ bool DefaultRobotHWSim::initSim(
-     if (joint_control_methods_[j] != EFFORT)
-     {
-       // Initialize the PID controller. If no PID gain values are found, use joint->SetAngle() or
--      // joint->SetVelocity() to control the joint.
-+      // joint->SetParam("vel") to control the joint.
-       const ros::NodeHandle nh(model_nh, "/gazebo_ros_control/pid_gains/" +
-                                joint_names_[j]);
-       if (pid_controllers_[j].init(nh, true))
-@@ -216,10 +216,14 @@ bool DefaultRobotHWSim::initSim(
-       }
-       else
-       {
--        // joint->SetMaxForce() must be called if joint->SetAngle() or joint->SetVelocity() are
--        // going to be called. joint->SetMaxForce() must *not* be called if joint->SetForce() is
-+        // joint->SetParam("fmax") must be called if joint->SetAngle() or joint->SetParam("vel") are
-+        // going to be called. joint->SetParam("fmax") must *not* be called if joint->SetForce() is
-         // going to be called.
-+#if GAZEBO_MAJOR_VERSION > 2
-+        joint->SetParam("fmax", 0, joint_effort_limits_[j]);
-+#else
-         joint->SetMaxForce(0, joint_effort_limits_[j]);
-+#endif
-       }
-     }
-   }
-@@ -327,7 +331,11 @@ void DefaultRobotHWSim::writeSim(ros::Time time, ros::Duration period)
-         break;
-       case VELOCITY:
-+#if GAZEBO_MAJOR_VERSION > 2
-+        sim_joints_[j]->SetParam("vel", 0, e_stop_active_ ? 0 : joint_velocity_command_[j]);
-+#else
-         sim_joints_[j]->SetVelocity(0, e_stop_active_ ? 0 : joint_velocity_command_[j]);
-+#endif
-         break;
-       case VELOCITY_PID:
diff --git a/dev-ros/gazebo_ros_control/gazebo_ros_control-2.5.1.ebuild b/dev-ros/gazebo_ros_control/gazebo_ros_control-2.5.1.ebuild
deleted file mode 100644 (file)
index 65b2ca7..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
-KEYWORDS="~amd64"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="ROS control plugins for gazebo"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
-       dev-ros/roscpp
-       dev-ros/gazebo_ros
-       dev-ros/control_toolbox
-       dev-ros/controller_manager
-       dev-ros/hardware_interface
-       dev-ros/transmission_interface
-       dev-ros/pluginlib
-       dev-ros/joint_limits_interface
-       dev-ros/urdf
-       sci-electronics/gazebo
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gazebo7.patch" )
diff --git a/dev-ros/gazebo_ros_control/gazebo_ros_control-2.5.2.ebuild b/dev-ros/gazebo_ros_control/gazebo_ros_control-2.5.2.ebuild
deleted file mode 100644 (file)
index a8ee997..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
-KEYWORDS="~amd64"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="ROS control plugins for gazebo"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
-       dev-ros/roscpp
-       dev-ros/gazebo_ros
-       dev-ros/control_toolbox
-       dev-ros/controller_manager
-       dev-ros/hardware_interface
-       dev-ros/transmission_interface
-       dev-ros/pluginlib
-       dev-ros/joint_limits_interface
-       dev-ros/urdf
-       sci-electronics/gazebo
-"
-DEPEND="${RDEPEND}"
diff --git a/dev-ros/gazebo_ros_control/gazebo_ros_control-2.5.3.ebuild b/dev-ros/gazebo_ros_control/gazebo_ros_control-2.5.3.ebuild
deleted file mode 100644 (file)
index a8ee997..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
-KEYWORDS="~amd64"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="ROS control plugins for gazebo"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
-       dev-ros/roscpp
-       dev-ros/gazebo_ros
-       dev-ros/control_toolbox
-       dev-ros/controller_manager
-       dev-ros/hardware_interface
-       dev-ros/transmission_interface
-       dev-ros/pluginlib
-       dev-ros/joint_limits_interface
-       dev-ros/urdf
-       sci-electronics/gazebo
-"
-DEPEND="${RDEPEND}"
diff --git a/dev-ros/gazebo_ros_control/gazebo_ros_control-2.5.6.ebuild b/dev-ros/gazebo_ros_control/gazebo_ros_control-2.5.6.ebuild
deleted file mode 100644 (file)
index a8ee997..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
-KEYWORDS="~amd64"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="ROS control plugins for gazebo"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
-       dev-ros/roscpp
-       dev-ros/gazebo_ros
-       dev-ros/control_toolbox
-       dev-ros/controller_manager
-       dev-ros/hardware_interface
-       dev-ros/transmission_interface
-       dev-ros/pluginlib
-       dev-ros/joint_limits_interface
-       dev-ros/urdf
-       sci-electronics/gazebo
-"
-DEPEND="${RDEPEND}"