dev-python/pytest-django: Bump to 3.9.0
authorMichał Górny <mgorny@gentoo.org>
Sat, 4 Apr 2020 05:32:33 +0000 (07:32 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 4 Apr 2020 17:04:07 +0000 (19:04 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-django/Manifest
dev-python/pytest-django/pytest-django-3.9.0.ebuild [new file with mode: 0644]

index a7539ffbf8f12c9d4d97cd0f9bbc2681cee2530e..6b064a9364ef70b219d8ad33940087583ac57daf 100644 (file)
@@ -1 +1,2 @@
 DIST pytest-django-3.8.0.tar.gz 70013 BLAKE2B 75e2ebf6a3a61cfabdc59ceb6f60a85ab4e257b22e3ff55bcda122a370317bf91a9f90640d9edc17da2cc3bdc6dcf6e84dd1e3438dff91b07f5682713804d513 SHA512 3ce45b08f913c3e20b679c7f7a07818ffab7088fd90757794e1807db2025d655c195304da3ca3905c8ddb58fc9708000dc492f4114df8f4e7bfdb1285ebd997a
+DIST pytest-django-3.9.0.tar.gz 70498 BLAKE2B 0f3cf7ffd528f00dd0c7dd6babcb64833ec3684c7b62dcb8757b0f90cdcdddabffdbff240774ed6fb2a294e27da2acd7f396298ff2884be6e5b4c8d9c632d008 SHA512 92985e66f47c91363d19fe2bfe8ccab14212be577692f90923dbbae4c8d406cf698796d485af2b721863392810fc07c6f11ada0c61589cd1861f0d34a732effe
diff --git a/dev-python/pytest-django/pytest-django-3.9.0.ebuild b/dev-python/pytest-django/pytest-django-3.9.0.ebuild
new file mode 100644 (file)
index 0000000..d8944a9
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="https://pypi.org/project/pytest-django/ https://pytest-django.readthedocs.org https://github.com/pytest-dev/pytest-django"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+       >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"