dev-python/pillow: Spawn one virtx for all testing
authorMichał Górny <mgorny@gentoo.org>
Mon, 15 Jul 2019 12:35:42 +0000 (14:35 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 15 Jul 2019 12:51:33 +0000 (14:51 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pillow/pillow-6.1.0.ebuild

index 7a4b5480a0a8d91149a82c443bea07c55b827940..ca751b2624ca3ed6de68a41fcb7e5ef2894d7928 100644 (file)
@@ -79,10 +79,14 @@ python_compile_all() {
        use doc && emake -C docs html
 }
 
+src_test() {
+       virtx distutils-r1_src_test
+}
+
 python_test() {
        "${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
        # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
-       virtx pytest -vv -p no:relaxed
+       pytest -vv -p no:relaxed || die "Tests fail with ${EPYTHON}"
 }
 
 python_install() {