dev-lang/micropython: Remove redundant
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 09:44:50 +0000 (11:44 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 09:44:50 +0000 (11:44 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-lang/micropython/Manifest
dev-lang/micropython/micropython-1.9.3.ebuild [deleted file]
dev-lang/micropython/micropython-1.9.4.ebuild [deleted file]

index 688bf57b4ed59fd419984f2a29d69a91b66f27e3..1ac72acd2024d8ecb9bf2bda7ad042ccb63bc2a8 100644 (file)
@@ -1,3 +1 @@
 DIST micropython-1.11.tar.gz 23010708 BLAKE2B 8deb29f2a27b8299f62c8c3d332654889e610ddc6854dc38c6cf7504c89f2f9cbbacccdc2d8e471d96b8bb28bbb920fe7ec1b8fd49b14209924262f54687c3c1 SHA512 255860e56bf51c4f35a00cf66fff3ee37fbef1e0d674af6ed580367d8b3d2d60fb88609a675e8f322fd466a23006e38078b67edd6f306e639d6be12abb2972d2
-DIST micropython-1.9.3.tar.gz 17311734 BLAKE2B 31ebdedc402af53b205a854aa61b59c694cc893c7f80e4b84196c5d44527545f442628938b7dd923ed9086a79e00ff899682548115224613e888eb8a37dd5ae3 SHA512 1b4358913ed78df66314c9a62636c7b8d086c731459e3bee1fab8695286dc03b6ec7594b2f9b8105e2a6d62190d95c6ad5351fb64c666c1ea54b9535193ee8a8
-DIST micropython-1.9.4.tar.gz 18957648 BLAKE2B bc4dc4ef6623adbda64c9e03137860a7b9ce7d2d181434cb993438752ec39a4ea7cf7cf7a14736c57bdc2ea9c3f856b0dbe2d92fc0e1cbef99112427583ad665 SHA512 9995c983c93fb1280e60d7c52a10930a6a3de8d589a0f4264a9a4a4fede7c37e27ed4871c4c9092aec3fb33028064beb8c5eb19b7956e8f0c5d3b2a82ffa9932
diff --git a/dev-lang/micropython/micropython-1.9.3.ebuild b/dev-lang/micropython/micropython-1.9.3.ebuild
deleted file mode 100644 (file)
index e519fa6..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Python implementation for microcontrollers"
-HOMEPAGE="https://github.com/micropython/micropython"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       virtual/libffi
-       virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}/${P}-prevent-stripping.patch" )
-
-src_compile() {
-       cd ports/unix || die
-
-       # 1) don't die on compiler warnings
-       # 2) remove /usr/local prefix references in favour of /usr
-       sed -i \
-               -e 's#-Werror##g;' \
-               -e 's#\/usr\/local#\/usr#g;' \
-               Makefile || die
-       emake CC="$(tc-getCC)" axtls
-       emake CC="$(tc-getCC)"
-}
-
-src_test() {
-       # XXX: find out why these tests fail
-       rm -v tests/misc/recursive_iternext* || die
-
-       cd ports/unix || die
-       emake test
-}
-
-src_install() {
-       pushd ports/unix > /dev/null || die
-       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" DESTDIR="${D}" install
-       popd > /dev/null || die
-
-       # remove .git files
-       find tools -type f -name '.git*' -exec rm {} \; || die
-
-       dodoc -r tools
-       einstalldocs
-}
diff --git a/dev-lang/micropython/micropython-1.9.4.ebuild b/dev-lang/micropython/micropython-1.9.4.ebuild
deleted file mode 100644 (file)
index 0b1864d..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Python implementation for microcontrollers"
-HOMEPAGE="https://github.com/micropython/micropython"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       virtual/libffi
-       virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}/${P}-prevent-stripping.patch" )
-
-src_compile() {
-       cd ports/unix || die
-
-       # 1) don't die on compiler warnings
-       # 2) remove /usr/local prefix references in favour of /usr
-       sed -i \
-               -e 's#-Werror##g;' \
-               -e 's#\/usr\/local#\/usr#g;' \
-               Makefile || die
-       emake CC="$(tc-getCC)" axtls
-       emake CC="$(tc-getCC)"
-}
-
-src_test() {
-       # TODO: find out why these tests fail
-       rm -v tests/stress/recursive_iternext* || die
-
-       cd ports/unix || die
-       emake test
-}
-
-src_install() {
-       pushd ports/unix > /dev/null || die
-       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" DESTDIR="${D}" install
-       popd > /dev/null || die
-
-       dobin "${S}/mpy-cross/mpy-cross"
-
-       # remove .git files
-       find tools -type f -name '.git*' -exec rm {} \; || die
-
-       dodoc -r tools
-       einstalldocs
-}