QA: which -> type -P
authorDanny van Dyk <kugelfang@gentoo.org>
Tue, 13 Mar 2007 00:35:42 +0000 (00:35 +0000)
committerDanny van Dyk <kugelfang@gentoo.org>
Tue, 13 Mar 2007 00:35:42 +0000 (00:35 +0000)
Package-Manager: portage-2.1.2.1-r1

sci-geosciences/grass/ChangeLog
sci-geosciences/grass/grass-6.2.0-r1.ebuild
sci-geosciences/mapserver/ChangeLog
sci-geosciences/mapserver/mapserver-4.10.0.ebuild

index 6a63e7be04e986670a2fc296fc12094af24b5402..63ed4c104fe53f94a96eaae329081621394ebc23 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for sci-geosciences/grass
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.32 2007/02/10 23:21:53 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.33 2007/03/13 00:32:26 kugelfang Exp $
+
+  13 Mar 2007; Danny van Dyk <kugelfang@gentoo.org> grass-6.2.0-r1.ebuild:
+  QA: which -> type -P
 
   10 Feb 2007; Christian Faulhammer <opfer@gentoo.org> grass-6.0.1.ebuild:
   moved from tcltk USE flag to tk, see bug 17808
index bf5510e14715a510ae468f8fff94e629da2240b6..a620ef5fb821cf563d914fb528a28ec0b008bf71 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.2.0-r1.ebuild,v 1.1 2007/01/29 01:57:03 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.2.0-r1.ebuild,v 1.2 2007/03/13 00:32:26 kugelfang Exp $
 
 inherit eutils autotools
 
@@ -108,7 +108,7 @@ src_unpack() {
 src_compile() {
        local myconf
        myconf="--prefix=/usr --with-cxx --enable-shared \
-               --with-gdal=$(which gdal-config) --with-curses --with-proj \
+               --with-gdal=$(type -P gdal-config) --with-curses --with-proj \
                --with-proj-includes=/usr/include --with-proj-libs=/usr/lib \
                --with-proj-share=/usr/share/proj"
 
index 003eee5aee6692a07a480b903a147c76ff2ce5c3..a485d293177d13edef624137c9cbe0e600135295 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for sci-geosciences/mapserver
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/ChangeLog,v 1.1 2006/11/25 03:39:43 djay Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/ChangeLog,v 1.2 2007/03/13 00:35:42 kugelfang Exp $
+
+  13 Mar 2007; Danny van Dyk <kugelfang@gentoo.org> mapserver-4.10.0.ebuild:
+  QA: which -> type -P
 
 *mapserver-4.10.0 (25 Nov 2006)
 
index 98ab7452e707ee8df22b40589af5e59433741e09..71350e1a75ac21f33d671fa6a441226a38b33fce 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/mapserver-4.10.0.ebuild,v 1.3 2007/02/07 07:43:55 djay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/mapserver-4.10.0.ebuild,v 1.4 2007/03/13 00:35:42 kugelfang Exp $
 
 PHP_EXT_NAME="php_mapscript php_proj"
 RUBY_OPTIONAL="yes"
@@ -103,7 +103,7 @@ src_compile() {
        myconf="--with-httpd=${APACHECTL/'ctl'/} --with-freetype"
 
        if use geos; then
-               myconf="${myconf} --with-geos=$(which geos-config)"
+               myconf="${myconf} --with-geos=$(type -P geos-config)"
        fi
 
        local MYGPUSE="wfs wcs wfsclient"