mail-client/claws-mail: Bump to version 3.17.5
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 24 Feb 2020 09:06:03 +0000 (10:06 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 24 Feb 2020 09:06:15 +0000 (10:06 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
mail-client/claws-mail/Manifest
mail-client/claws-mail/claws-mail-3.17.5.ebuild [new file with mode: 0644]

index 5a699dafc777f2e9b1c5cfebe08dbacd9b4ef338..84dcd62c129c96949dda46438766252bd2f01266 100644 (file)
@@ -1,2 +1,3 @@
 DIST claws-mail-3.17.3.tar.xz 6164392 BLAKE2B ac0781c4c7e4423f4a8b494a9bd007d62443e8c540feaeef089ca65f641da5ecabfa2c5c0662750d6f58c8913c1d95750a3dfb6b4628e573b0105f8f526bc066 SHA512 b562d785eaedbdec408c4a3db8f4d9326183266fe314509a189c9e1220f15b4f41ccd9d8c58c5194c0267842e8efe900e88eb17c0d17d6069e2543870efa5ef8
 DIST claws-mail-3.17.4.tar.xz 6280252 BLAKE2B 8ddce2e5dfb3ae0ddb646c4f5a81d7e4c3834d2fa7a7f7a7326bf6e160291db4ba5954737bb61a4ae86ebaaab72a695d2e351fe2cf89b187eba4341f5d9b0cd9 SHA512 4fc3b04d89c84b068654902d3d4f8ba66ec86c4ea9c4bd145fb3169dd26a2fcfc26adc8367b0ed90c69d095f6b1717ba3a9a52cc6d3e310a9dad1c3f733d8012
+DIST claws-mail-3.17.5.tar.xz 6296232 BLAKE2B c80d0be361207cd8d28e7dec9f7e1258b411555a558b43a1843ad0b7f94f91b8695972836aec3581418ea5e88ca71505ff7c206ecc4f2b175fe1b6e4d47681ea SHA512 ec6a4723fc4e826739c7391e52970bf9c398f6bdb23780b689725e1220a880e04ea9161597d0213c86e133884af0326abd44ccf4daaa51e3c9312a9f50e63568
diff --git a/mail-client/claws-mail/claws-mail-3.17.5.ebuild b/mail-client/claws-mail/claws-mail-3.17.5.ebuild
new file mode 100644 (file)
index 0000000..bdd1b7d
--- /dev/null
@@ -0,0 +1,220 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit autotools desktop python-single-r1 xdg
+
+DESCRIPTION="An email client (and news reader) based on GTK+"
+HOMEPAGE="https://www.claws-mail.org/"
+
+if [[ "${PV}" == 9999 ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="git://git.claws-mail.org/claws.git"
+else
+       SRC_URI="https://www.claws-mail.org/download.php?file=releases/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+SLOT="0"
+LICENSE="GPL-3"
+
+IUSE="archive bogofilter calendar clamav dbus debug dillo doc gdata +gnutls +imap ipv6 ldap +libcanberra +libindicate +libnotify litehtml networkmanager nls nntp +notification pda pdf perl +pgp python rss session sieve smime spamassassin spam-report spell startup-notification svg valgrind xface"
+
+REQUIRED_USE="libcanberra? ( notification )
+       libindicate? ( notification )
+       libnotify? ( notification )
+       networkmanager? ( dbus )
+       python? ( ${PYTHON_REQUIRED_USE} )
+       smime? ( pgp )"
+
+COMMONDEPEND="
+       dev-libs/nettle:=
+       net-mail/ytnef
+       sys-libs/zlib:=
+       x11-libs/cairo
+       x11-libs/gdk-pixbuf:2[jpeg]
+       >=x11-libs/gtk+-2.24:2
+       x11-libs/libX11
+       x11-libs/pango
+       archive? (
+               app-arch/libarchive
+               >=net-misc/curl-7.9.7
+       )
+       bogofilter? ( mail-filter/bogofilter )
+       calendar? (
+               >=dev-libs/libical-2.0.0:=
+               >=net-misc/curl-7.9.7
+       )
+       dbus? (
+               >=dev-libs/dbus-glib-0.60
+               sys-apps/dbus
+       )
+       gdata? ( >=dev-libs/libgdata-0.17.2 )
+       dillo? ( www-client/dillo )
+       gnutls? ( >=net-libs/gnutls-3.0 )
+       imap? ( >=net-libs/libetpan-0.57 )
+       ldap? ( >=net-nds/openldap-2.0.7 )
+       litehtml? (
+               >=dev-libs/glib-2.36:2
+               >=dev-libs/gumbo-0.10
+               net-misc/curl
+               media-libs/fontconfig
+       )
+       nls? ( >=sys-devel/gettext-0.18 )
+       nntp? ( >=net-libs/libetpan-0.57 )
+       notification? (
+               dev-libs/glib:2
+               libcanberra? (  media-libs/libcanberra[gtk] )
+               libindicate? ( dev-libs/libindicate:3[gtk] )
+               libnotify? ( x11-libs/libnotify )
+       )
+       pda? ( >=app-pda/jpilot-0.99 )
+       pdf? ( app-text/poppler[cairo] )
+       pgp? ( >=app-crypt/gpgme-1.0.0 )
+       session? (
+               x11-libs/libICE
+               x11-libs/libSM
+       )
+       smime? ( >=app-crypt/gpgme-1.0.0 )
+       spam-report? ( >=net-misc/curl-7.9.7 )
+       spell? ( >=app-text/enchant-1.0.0:= )
+       startup-notification? ( x11-libs/startup-notification )
+       svg? ( >=gnome-base/librsvg-2.40.5 )
+       valgrind? ( dev-util/valgrind )
+"
+
+DEPEND="${COMMONDEPEND}
+       xface? ( >=media-libs/compface-1.4 )
+"
+BDEPEND="
+       app-arch/xz-utils
+       virtual/pkgconfig
+"
+RDEPEND="${COMMONDEPEND}
+       app-misc/mime-types
+       x11-misc/shared-mime-info
+       clamav? ( app-antivirus/clamav )
+       networkmanager? ( net-misc/networkmanager )
+       pdf? ( app-text/ghostscript-gpl )
+       perl? ( dev-lang/perl:= )
+       python? (
+               ${PYTHON_DEPS}
+               >=dev-python/pygtk-2.10.3
+       )
+       rss? (
+               dev-libs/libxml2
+               net-misc/curl
+       )
+"
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       xdg_src_prepare
+       eautoreconf
+}
+
+src_configure() {
+       # Don't use libsoup-gnome (bug #565924)
+       export HAVE_LIBSOUP_GNOME=no
+
+       local myeconfargs=(
+               --disable-bsfilter-plugin
+               --disable-fancy-plugin
+               --disable-generic-umpc
+               --enable-acpi_notifier-plugin
+               --enable-address_keeper-plugin
+               --enable-alternate-addressbook
+               --enable-att_remover-plugin
+               --enable-attachwarner-plugin
+               --enable-fetchinfo-plugin
+               --enable-mailmbox-plugin
+               --enable-newmail-plugin
+               --enable-tnef_parse-plugin
+               --with-password-encryption=$(usex gnutls gnutls old)
+               $(use_enable archive archive-plugin)
+               $(use_enable bogofilter bogofilter-plugin)
+               $(use_enable calendar vcalendar-plugin)
+               $(use_enable clamav clamd-plugin)
+               $(use_enable dbus)
+               $(use_enable debug crash-dialog)
+               $(use_enable dillo dillo-plugin)
+               $(use_enable doc manual)
+               $(use_enable gdata gdata-plugin)
+               $(use_enable gnutls)
+               $(use_enable ipv6)
+               $(use_enable ldap)
+               $(use_enable litehtml litehtml_viewer-plugin)
+               $(use_enable networkmanager)
+               $(use_enable nls)
+               $(use_enable notification notification-plugin)
+               $(use_enable pda jpilot)
+               $(use_enable pdf pdf_viewer-plugin)
+               $(use_enable perl perl-plugin)
+               $(use_enable pgp pgpcore-plugin)
+               $(use_enable pgp pgpinline-plugin)
+               $(use_enable pgp pgpmime-plugin)
+               $(use_enable python python-plugin)
+               $(use_enable rss rssyl-plugin)
+               $(use_enable session libsm)
+               $(use_enable sieve managesieve-plugin)
+               $(use_enable smime smime-plugin)
+               $(use_enable spam-report spam_report-plugin)
+               $(use_enable spamassassin spamassassin-plugin)
+               $(use_enable spell enchant)
+               $(use_enable startup-notification)
+               $(use_enable svg)
+               $(use_enable valgrind valgrind)
+               $(use_enable xface compface)
+       )
+
+       # libetpan is needed if user wants nntp or imap functionality
+       if use imap || use nntp ; then
+               myeconfargs+=( --enable-libetpan )
+       else
+               myeconfargs+=( --disable-libetpan )
+       fi
+
+       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       local DOCS=( AUTHORS ChangeLog* INSTALL* NEWS README* TODO* )
+       default
+
+       # Makefile install claws-mail.png in /usr/share/icons/hicolor/48x48/apps
+       # => also install it in /usr/share/pixmaps for other desktop envs
+       # => also install higher resolution icons in /usr/share/icons/hicolor/...
+       insinto /usr/share/pixmaps
+       doins ${PN}.png
+       local size
+       for size in 64 128 ; do
+               newicon -s ${size} ${PN}-${size}x${size}.png ${PN}.png
+       done
+
+       docinto tools
+       dodoc tools/README*
+
+       domenu ${PN}.desktop
+
+       einfo "Installing extra tools"
+       cd "${S}"/tools || die
+       exeinto /usr/$(get_libdir)/${PN}/tools
+       doexe *.pl *.py *.conf *.sh
+       doexe tb2claws-mail update-po uudec uuooffice
+
+       # kill useless files
+       rm -f "${ED}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
+
+pkg_postinst() {
+       ewarn "When upgrading from version 3.9.0 or below some changes have happened:"
+       ewarn "- There are no individual plugins in mail-client/claws-mail-* anymore, but they are integrated mostly controlled through USE flags"
+       ewarn "- Plugins with no special dependencies are just built and can be loaded through the interface"
+       ewarn "- The gtkhtml2 and trayicon plugins have been dropped entirely"
+       xdg_pkg_postinst
+}