dev-java/gnu-jaf: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 31 Mar 2019 20:09:41 +0000 (22:09 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 1 Apr 2019 08:51:40 +0000 (10:51 +0200)
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11
RepoMan-Options: --force

dev-java/gnu-jaf/gnu-jaf-1.1.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/gnu-jaf/gnu-jaf-1.1.1-r1.ebuild b/dev-java/gnu-jaf/gnu-jaf-1.1.1-r1.ebuild
new file mode 100644 (file)
index 0000000..b71050b
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="GNU implementation of the JavaBeans Activation Framework"
+HOMEPAGE="https://www.gnu.org/software/classpathx/jaf/jaf.html"
+SRC_URI="mirror://gnu/classpathx/activation-${PV}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="1"
+KEYWORDS="amd64 ppc64 x86"
+
+DEPEND="
+       >=virtual/jdk-1.8"
+
+RDEPEND="
+       >=virtual/jre-1.8"
+
+S=${WORKDIR}/activation-${PV}
+
+EANT_BUILD_TARGET="activation.jar"
+
+DOCS=( AUTHORS ChangeLog )
+
+src_install() {
+       java-pkg_dojar activation.jar
+       einstalldocs
+       use doc && java-pkg_dojavadoc docs
+       use source && java-pkg_dosrc source/*
+}