dev-python/oauth2: version bump to 1.9.0_p1
authorDirkjan Ochtman <djc@gentoo.org>
Sat, 19 Sep 2015 12:57:01 +0000 (14:57 +0200)
committerDirkjan Ochtman <djc@gentoo.org>
Sat, 19 Sep 2015 12:57:34 +0000 (14:57 +0200)
Package-Manager: portage-2.2.20.1

dev-python/oauth2/Manifest
dev-python/oauth2/files/1.9.0_p1-exclude-tests.patch [new file with mode: 0644]
dev-python/oauth2/oauth2-1.9.0_p1.ebuild [new file with mode: 0644]

index e7e92e1a3a314afca452f6be0eb93dbae99de5b0..a4cc375ab2f7d749f1aa05d60fdd533715a224e8 100644 (file)
@@ -1 +1,2 @@
 DIST oauth2-1.5.211.tar.gz 18608 SHA256 82a38f674da1fa496c0fc4df714cbb058540bed72a30c50a2e344b0d984c4d21 SHA512 3f5606702d4e305c191c924cab01ee3fc7e170a26460c1d49031e3d9a296b3502d5e18edb1ec0e291abd61797cb47b7b2b8929eff33eb8bc9fd73434b3ab028a WHIRLPOOL bd262f4c6d324c048951addc158485bd81c12125fea8cf59545b2cb31c343c793a91cc892d27baeec54b2c62df818e5cb8e9b10196d4f9860fd6e62a37c7bffe
+DIST oauth2-1.9.0.post1.tar.gz 21306 SHA256 c006a85e7c60107c7cc6da1b184b5c719f6dd7202098196dfa6e55df669b59bf SHA512 a3b64eef331d4c4f59c275f14efb2dfb48ad60de47a59a88106f60d64428a09b76d8bedf08c98c113493968d83708b1478b4b61b2b5528b5b01fa22777daff4c WHIRLPOOL 11d7cdf610d297a909e8ae61bbdf8765b8ffbec4cf83cfa81a097619194bfbcec3ce8967e699b6ba56076c84e30fc5747c5f83895997b7e54e19a0c45ed39e5b
diff --git a/dev-python/oauth2/files/1.9.0_p1-exclude-tests.patch b/dev-python/oauth2/files/1.9.0_p1-exclude-tests.patch
new file mode 100644 (file)
index 0000000..ab9cd75
--- /dev/null
@@ -0,0 +1,11 @@
+--- setup.py.bak       2015-09-19 14:03:27.000000000 +0200
++++ setup.py   2015-09-19 14:03:43.000000000 +0200
+@@ -45,7 +45,7 @@
+         "Natural Language :: English",
+         "License :: OSI Approved :: MIT License"
+       ],
+-      packages = find_packages(),
++      packages = find_packages(exclude=['tests']),
+       install_requires = ['httplib2'],
+       license = "MIT License",
+       keywords="oauth",
diff --git a/dev-python/oauth2/oauth2-1.9.0_p1.ebuild b/dev-python/oauth2/oauth2-1.9.0_p1.ebuild
new file mode 100644 (file)
index 0000000..10d6a2e
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 pypy )
+
+inherit distutils-r1
+
+MY_P="${P/_p/.post}"
+
+DESCRIPTION="Library for OAuth version 1.0"
+HOMEPAGE="https://pypi.python.org/pypi/oauth2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="test"
+
+RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( ${RDEPEND}
+               dev-python/coverage[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+       )"
+
+PATCHES=( "${FILESDIR}/${PV}-exclude-tests.patch" )
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+       esetup.py test
+}