dev-python/rdflib: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:52:35 +0000 (09:52 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:52:35 +0000 (09:52 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/rdflib/Manifest
dev-python/rdflib/rdflib-4.2.1.ebuild [deleted file]

index 353dfc3e52be2b30db9c6b700ed6e359451127fd..75e53685eb1109cdb45cbaf39a0e7db2c52f87f2 100644 (file)
@@ -1,2 +1 @@
-DIST rdflib-4.2.1.tar.gz 889467 BLAKE2B cc5f675646ca7a55ff40d4d98eb138953d8763d8b44b5b495cdc9bb83df16d425214bb681f8f841e053a3cb4d52edd30988afcf2c301a96f699a70d9c129cca5 SHA512 49145f80a9e027847523faed059c16ec1de358bb9d8fc3ab4fd3bf95a88dd181986b1785deedf6e837cf0b064bd74ab8e27fbb5581e33310353da3546ae7b016
 DIST rdflib-4.2.2.tar.gz 905094 BLAKE2B fe17b5752f67c745bfdf4a160c2f5d49da19f0d85b6eddc4a65fa0ddb660de8bcc19c3ccecf893fb67f725b973cb94481374d9ee0c82072416a93e44952dba9b SHA512 efc24d8ce1080e59950cecc9c779ae0d63673c8690f74db1772f6c2dbf24d6f4de5214d5870a074bffe549b42d8d5f5d131df29bbfd174b763ae1f843aec7d5c
diff --git a/dev-python/rdflib/rdflib-4.2.1.ebuild b/dev-python/rdflib/rdflib-4.2.1.ebuild
deleted file mode 100644 (file)
index eb48466..0000000
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-PYTHON_REQ_USE="sqlite?,threads(+)"
-
-# The usual required for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1
-
-DESCRIPTION="RDF library containing a triple store and parser/serializer"
-HOMEPAGE="https://github.com/RDFLib/rdflib https://pypi.org/project/rdflib/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc berkdb examples mysql redland sqlite test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/isodate[${PYTHON_USEDEP}]
-       dev-python/html5lib[${PYTHON_USEDEP}]
-       dev-python/pyparsing[${PYTHON_USEDEP}]
-       berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
-       mysql? ( dev-python/mysql-python[$(python_gen_usedep python2_7)] )
-       redland? ( dev-libs/redland-bindings[python,$(python_gen_usedep python2_7)] )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
-               >=dev-python/nose-1.3.1-r1[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # Upstream manufactured .pyc files which promptly break distutils' src_test
-       find -name "*.py[oc~]" -delete || die
-
-       # Bug 358189; take out tests that attempt to connect to the network
-        sed -e "/'--with-doctest',/d" -e "/'--doctest-extension=.doctest',/d" \
-               -e "/'--doctest-tests',/d" -i run_tests.py || die
-
-       sed -e "s: 'sphinx.ext.intersphinx',::" -i docs/conf.py || die
-
-       # doc build requires examples folder at the upper level of docs
-       if use doc; then
-               cd docs || die
-               ln -sf ../examples . || die
-               cd ../ || die
-       fi
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       # https://github.com/RDFLib/rdflib/issues/510
-       if use doc; then
-               einfo ""; einfo "Several warnings and Errors present in the build"
-               einfo "For a complete build, it is required to install"
-               einfo "github.com/gjhiggins/n3_pygments_lexer and"
-               einfo "github.com/gjhiggins/sparql_pygments_lexer"
-               einfo "outside portage via pip or by cloning. These have not been"
-               einfo "given a tagged release by the author and are not in portage"
-               einfo ""
-               emake -C docs html
-       fi
-}
-
-python_test() {
-       # the default; nose with: --where=./ does not work for python3
-       if python_is_python3; then
-               pushd "${BUILD_DIR}/src/" > /dev/null
-               "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
-               popd > /dev/null
-       else
-               "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
-       fi
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       use examples && local EXAMPLES=( examples/. )
-
-       distutils-r1_python_install_all
-}