dev-libs/sord: bump 0.16.4
authorMiroslav Šulc <fordfrog@gentoo.org>
Thu, 19 Dec 2019 17:23:01 +0000 (18:23 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Thu, 19 Dec 2019 17:34:47 +0000 (18:34 +0100)
1) dropped python 2_7 and 3_5, added 3_{6,7,8}
2) updated deps

Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
dev-libs/sord/Manifest
dev-libs/sord/sord-0.16.4.ebuild [new file with mode: 0644]

index cc4ba82085e1a318c67c932dad7f5a673226f39e..1c3b93a6d65effd0b8503c94084eded8458c306b 100644 (file)
@@ -1 +1,2 @@
 DIST sord-0.16.0.tar.bz2 316331 BLAKE2B 27702600e48e14c75be18cc2b83705cdea1eed7158223ee685821ae80b18b61f5db82f804ee6a32236143cf8287ee875c3b3354edc6ccd1d4f25eaa3a04c785b SHA512 e18c6de62f2cbffedd4c200f6452f4fd37f719aed764ccc1b77c8da04a0f3394d47e8b57e19eefd6d600770926f505fdfa5da91564bbff5f4ead49f1adaba249
+DIST sord-0.16.4.tar.bz2 510920 BLAKE2B e52b659e8070dc63188225741d1bfa31480214e47b53b4834dd0bccc5dcd688b93fc65c894b25540d89dbb20b04d8fd1952dcc65999c2ae7b650065c80b387dc SHA512 98bb102cff5ab38d999c2f966597508076ccce54583a739810b0c28b4f3d570b2ef414605fc08361ecb11ac3184d3176f2f50c7c59c06cc50c3d522e26ed5576
diff --git a/dev-libs/sord/sord-0.16.4.ebuild b/dev-libs/sord/sord-0.16.4.ebuild
new file mode 100644 (file)
index 0000000..faef78b
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils multilib-build multilib-minimal
+
+DESCRIPTION="Library for storing RDF data in memory"
+HOMEPAGE="http://drobilla.net/software/sord/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-libs/libpcre
+       >=dev-libs/serd-0.30.0
+"
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       doc? ( app-doc/doxygen )
+       virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README.md" )
+
+src_prepare() {
+       sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+       default
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       waf-utils_src_configure \
+               --docdir=/usr/share/doc/${PF} \
+               $(multilib_native_usex doc --docs "") \
+               $(usex test --test "") \
+               $(usex static-libs --static "")
+}
+
+multilib_src_test() {
+       ./waf test || die
+}
+
+multilib_src_compile() {
+       waf-utils_src_compile
+       default
+}
+
+multilib_src_install() {
+       waf-utils_src_install
+       default
+}