app-crypt/qca: Drop 2.2.1
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 19 Mar 2020 11:42:31 +0000 (12:42 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 19 Mar 2020 11:42:31 +0000 (12:42 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-crypt/qca/Manifest
app-crypt/qca/qca-2.2.1.ebuild [deleted file]

index b72a547ab01d948a12f383f3023d35ba34c643c8..73f8c879420bd018ba3e1cbdd8b38f41d07c70f4 100644 (file)
@@ -1,2 +1 @@
-DIST qca-2.2.1.tar.xz 691676 BLAKE2B d5bcc0d6e791811e1efcdbf2e09916fe40ad682b0e59b2993c73a5bd79e09fc28facdec81259a982bee05223c8dfce78b9a6b729ca4e566c0901a13b91575379 SHA512 3a0e8aa7cf3ea9a7244facaf1d521ebca2753af37636e7bf5f21c57ae880ac9682ae7d6d9fa5ce41b73568ff9538214956b89cd41228c2cb828d9068c2031a9c
 DIST qca-2.3.0.tar.xz 729504 BLAKE2B 71cf9dfae00066c14e1055da1fa1a8e1210f538b1addfde1b99a9b26b1e8f7dd61e289d0f505b5ec04d5f4745216d4fd0f8be8f8de9e9cbf74123907ba703d0e SHA512 ca9251868e073834562fa62ffc64b3e7817c9ddadc6bc3fb99cf8b5c8d859969562170a98874be9590c617b2dd8e5590d2c83792554f54bb880c677902db22fe
diff --git a/app-crypt/qca/qca-2.2.1.ebuild b/app-crypt/qca/qca-2.2.1.ebuild
deleted file mode 100644 (file)
index 0f23610..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake qmake-utils
-
-DESCRIPTION="Qt Cryptographic Architecture (QCA)"
-HOMEPAGE="https://userbase.kde.org/QCA"
-SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="amd64 ~arm arm64 ~hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
-
-IUSE="botan debug doc examples gcrypt gpg logger nss pkcs11 sasl softstore +ssl test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
-       doc? ( app-doc/doxygen )
-"
-RDEPEND="
-       dev-qt/qtcore:5
-       botan? ( dev-libs/botan:= )
-       gcrypt? ( dev-libs/libgcrypt:= )
-       gpg? ( app-crypt/gnupg )
-       nss? ( dev-libs/nss )
-       pkcs11? (
-               dev-libs/openssl:0
-               dev-libs/pkcs11-helper
-       )
-       sasl? ( dev-libs/cyrus-sasl:2 )
-       ssl? ( >=dev-libs/openssl-1.0.1:0= )
-"
-DEPEND="${RDEPEND}
-       test? (
-               dev-qt/qtnetwork:5
-               dev-qt/qttest:5
-       )
-"
-
-PATCHES=( "${FILESDIR}/${PN}-disable-pgp-test.patch" )
-
-qca_plugin_use() {
-       echo -DWITH_${2:-$1}_PLUGIN=$(usex "$1")
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DQCA_FEATURE_INSTALL_DIR="${EPREFIX}$(qt5_get_mkspecsdir)/features"
-               -DQCA_PLUGINS_INSTALL_DIR="${EPREFIX}$(qt5_get_plugindir)"
-               $(qca_plugin_use botan)
-               $(qca_plugin_use gcrypt)
-               $(qca_plugin_use gpg gnupg)
-               $(qca_plugin_use logger)
-               $(qca_plugin_use nss)
-               $(qca_plugin_use pkcs11)
-               $(qca_plugin_use sasl cyrus-sasl)
-               $(qca_plugin_use softstore)
-               $(qca_plugin_use ssl ossl)
-               -DBUILD_TESTS=$(usex test)
-       )
-       cmake_src_configure
-}
-
-src_test() {
-       local -x QCA_PLUGIN_PATH="${BUILD_DIR}/lib/qca"
-       cmake_src_test
-}
-
-src_install() {
-       cmake_src_install
-
-       if use doc; then
-               pushd "${BUILD_DIR}" >/dev/null || die
-               doxygen Doxyfile || die
-               dodoc -r apidocs/html
-               popd >/dev/null || die
-       fi
-
-       if use examples; then
-               dodoc -r "${S}"/examples
-       fi
-}