go-module.eclass: replace GOFLAGS if EGO_VENDOR is being used
authorWilliam Hubbs <william.hubbs@sony.com>
Tue, 10 Mar 2020 22:44:16 +0000 (17:44 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Tue, 10 Mar 2020 22:48:13 +0000 (17:48 -0500)
We can't repeat the -mod flag, so we need to replace the GOFLAGS if
EGO_VENDOR is being used.

Closes: https://bugs.gentoo.org/7111640

Signed-off-by: William Hubbs <williamh@gentoo.org>
eclass/go-module.eclass

index c3ad5159bad80fb00a339672f3b7e89d2c1a0b1e..4edffa70e42b17ba18e274f477a5216c4e7c886b 100644 (file)
@@ -388,7 +388,9 @@ _go-module_src_unpack_vendor() {
                        -f "${DISTDIR}/${tarball}" || die
                eend
        done
-       [[ ${#EGO_VENDOR[@]} -gt 0 ]] && GOFLAGS+=" -mod=vendor"
+       # replace GOFLAGS if EGO_VENDOR is being used
+       [[ ${#EGO_VENDOR[@]} -gt 0 ]] &&
+               GOFLAGS="-v -x -mod=vendor"
        eqawarn "${P}.ebuild: EGO_VENDOR will be removed in the future."
        eqawarn "Please request that the author migrate to EGO_SUM."
 }