sys-process/evisum: bump to 0.2.2
authorJoonas Niilola <juippis@gmail.com>
Wed, 19 Jun 2019 03:05:24 +0000 (06:05 +0300)
committerMichał Górny <mgorny@gentoo.org>
Wed, 19 Jun 2019 12:24:58 +0000 (14:24 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Joonas Niilola <juippis@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12256
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-process/evisum/Manifest
sys-process/evisum/evisum-0.2.2.ebuild [new file with mode: 0644]
sys-process/evisum/files/evisum-0.2.2-respect-cflags-ldflags.patch [new file with mode: 0644]

index d4b5e0a7eb23c376745d72d09275f87af9318603..b36aeb906432fc736c57f424a37f4306f3974fef 100644 (file)
@@ -1 +1,2 @@
 DIST evisum-0.2.0.tar.xz 84340 BLAKE2B ef950f9cab3e8b6e911a62e4a2338f4ce3b80b92c00a9d7a26c3e1929ad140d04dd46ecc96487205b07027a959f772ec2eb437509efdadffce7a496a2784391a SHA512 d0d071b652477f8e25a913d8424245e019f2b418de8886641b6a550845e59a5b55f4e5319530519834d8c699a8a4cdd1a6512271e321a53b1e6d64dc9700a40d
+DIST evisum-0.2.2.tar.xz 84984 BLAKE2B f514faae5fa1286ebc862e7d58d406ebffa700a41be6c90576a91399abd83329ff0b271bdb964140e4cd698b8cf4fc1c7198b4dee9d2467b64a21013623ef193 SHA512 06fb235a61093c5aa33a8171418a80a94e311ebdbc362fc0229019e24e4e9d933a491fac94be49ca72180b5ce81b1cee133e46a75462527a343c67ba46fdffe9
diff --git a/sys-process/evisum/evisum-0.2.2.ebuild b/sys-process/evisum/evisum-0.2.2.ebuild
new file mode 100644 (file)
index 0000000..5df0392
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="System and process monitor written with EFL"
+HOMEPAGE="https://www.enlightenment.org/"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/efl"
+RDEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )"
+
+PATCHES=( "${FILESDIR}/${P}-respect-cflags-ldflags.patch" )
+
+src_install() {
+       emake PREFIX="${D}"/usr install
+       einstalldocs
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}
diff --git a/sys-process/evisum/files/evisum-0.2.2-respect-cflags-ldflags.patch b/sys-process/evisum/files/evisum-0.2.2-respect-cflags-ldflags.patch
new file mode 100644 (file)
index 0000000..5884fb2
--- /dev/null
@@ -0,0 +1,13 @@
+diff -Naur a/src/tingle/makefile b/src/tingle/makefile
+--- a/src/tingle/makefile      2019-06-09 21:09:50.677101222 +0300
++++ b/src/tingle/makefile      2019-06-19 05:57:15.196603384 +0300
+@@ -1,7 +1,7 @@
+ PROGRAM=tingle
+ SOURCES=tingle.c
+-CFLAGS=-O2 -Wall -pedantic -std=c99 -lpthread
+-LDFLAGS=-lm -pthread
++CFLAGS+=-Wall -pedantic -std=c99 -lpthread
++LDFLAGS+=-lm -pthread
+ HAVE_ALSA := 0
+ ALSA_TEST := $(shell pkg-config --exists alsa 1>&2 2>/dev/null; echo $$?)