dev-ml/js_of_ocaml: bump to 2.8.4
authorAlexis Ballier <aballier@gentoo.org>
Thu, 22 Dec 2016 18:51:57 +0000 (19:51 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 22 Dec 2016 20:07:32 +0000 (21:07 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ml/js_of_ocaml/Manifest
dev-ml/js_of_ocaml/js_of_ocaml-2.8.4.ebuild [new file with mode: 0644]

index 7cd799100721a263f732faa8229731bbfbda0644..5f4b5ea5faa22319634e1d60683574ab44c84062 100644 (file)
@@ -1 +1,2 @@
 DIST js_of_ocaml-2.8.3.tar.gz 1335811 SHA256 a77e9d4896431742604cba69fb87f9022587de86f2c6d41a6b58e9c24b103c77 SHA512 89908f3da1846f4fe24e1109ba262507221ed67d58bec1d8b7c53ec82438febbab66bdb3bec697e2880842253777167ef1563687cae414426e8ea1dcc00a323a WHIRLPOOL b299214ed367f7aa2252a76a7d49f68f219aaf3ab9901eafa354e937a7dbe4913657a6c1c6fdc85337d63c04b90a5f835b3cf9c321840528188a496f6bfc3d37
+DIST js_of_ocaml-2.8.4.tar.gz 1344082 SHA256 74edd38a964fcee930778a908c896b5c9795f64fc34a3c58361ccfa441811725 SHA512 8dc65bac7d60f2d3534e31e0fddb061f1b97bfd8146b1a34b4a1a516574c6a39f66d115646aa9767b7e24a51ec76949b05841088601f97d76972c8899a50c4fd WHIRLPOOL bc444184519ae90d308ae4675078e1d5fd461ea32f4dccf5e74bab25f0a0e8ba49d229f951205effd676b337656633fb7046cd908c2167799253dcee0a61f20f
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-2.8.4.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-2.8.4.ebuild
new file mode 100644 (file)
index 0000000..1eb80bd
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="A compiler from OCaml bytecode to javascript"
+HOMEPAGE="http://ocsigen.org/js_of_ocaml/"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+       inherit git-r3
+       SRC_URI=""
+       EGIT_REPO_URI="https://github.com/ocsigen/js_of_ocaml"
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/ocsigen/js_of_ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+IUSE="+async +ocamlopt doc +deriving +ppx +ppx-deriving +react +xml X"
+
+RDEPEND="
+       >=dev-lang/ocaml-3.12:=[ocamlopt?,X?]
+       >=dev-ml/lwt-2.4.4:=[camlp4(+)]
+       async? ( dev-ml/async_kernel:= )
+       react? ( dev-ml/react:=  dev-ml/reactiveData:= )
+       xml? ( >=dev-ml/tyxml-4:= )
+       ppx? ( dev-ml/ppx_tools:= )
+       ppx-deriving? ( dev-ml/ppx_deriving:= )
+       dev-ml/cmdliner:=
+       dev-ml/menhir:=
+       dev-ml/ocaml-base64:=
+       dev-ml/camlp4:=
+       dev-ml/cppo:=
+       dev-ml/uchar:=
+       dev-ml/ocamlbuild:=
+       deriving? ( >=dev-ml/deriving-0.6:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+       printf "\n\n" >> Makefile.conf
+       use ocamlopt || echo "BEST := byte" >> Makefile.conf
+       use ocamlopt || echo "NATDYNLINK := NO" >> Makefile.conf
+       use deriving || echo "WITH_DERIVING := NO" >> Makefile.conf
+       use X || echo "WITH_GRAPHICS := NO" >> Makefile.conf
+       use react || echo "WITH_REACT := NO" >> Makefile.conf
+       use ppx || echo "WITH_PPX := NO" >> Makefile.conf
+       use ppx-deriving || echo "WITH_PPX_PPX_DERIVING := NO" >> Makefile.conf
+       use async || echo "WITH_ASYNC := NO" >> Makefile.conf
+}
+
+src_compile() {
+       emake -j1
+       use doc && emake doc
+}
+
+src_install() {
+       findlib_src_preinst
+       emake BINDIR="${ED}/usr/bin/" install
+       dodoc CHANGES README.md
+       use doc && dohtml -r doc/api/html/
+}