app-emulation/img: Use -mod vendor
authorManuel Rüger <mrueg@gentoo.org>
Mon, 7 Oct 2019 14:21:26 +0000 (16:21 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Mon, 7 Oct 2019 14:21:26 +0000 (16:21 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
app-emulation/img/img-0.5.7.ebuild

index a83d24d7c2810c0f7c452973f51d17512e52f38c..21373b5f486d6ac3b7210ea633f796c33b46f7fa 100644 (file)
@@ -21,7 +21,7 @@ RESTRICT="test"
 src_compile() {
        local TAGS=$(usex seccomp 'seccomp' '')
        pushd src/${EGO_PN} || die
-       GOPATH="${S}" go build -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+       GOPATH="${S}" go build -mod vendor -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
        popd || die
 }