net-proxy/trojan: version bump to 1.10.0, drop old.
authorYangMame <me@yangmame.org>
Tue, 15 Jan 2019 02:18:05 +0000 (10:18 +0800)
committerPatrice Clement <monsieurp@gentoo.org>
Sat, 19 Jan 2019 12:10:02 +0000 (13:10 +0100)
Signed-off-by: Xin Yang <yangmame@icloud.com>
Closes: https://github.com/gentoo/gentoo/pull/10835
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
net-proxy/trojan/Manifest
net-proxy/trojan/trojan-1.10.0.ebuild [moved from net-proxy/trojan/trojan-1.8.1.ebuild with 90% similarity]
net-proxy/trojan/trojan-1.9.0.ebuild [deleted file]

index a19c9e2df558c4ac66546e50234390fc7c34a94c..a98743f222c7bdd79d587d8ac7630a91840b3c41 100644 (file)
@@ -1,2 +1 @@
-DIST trojan-1.8.1.tar.gz 37199 BLAKE2B be93a119ca95e5f4151db6ab58ffaa123d5bd304247d7835ca34ba870808d7e246d551c204d60ffb2a982f2fcb2c35ada1d9823e7f931b36377f99ebd0f48bd6 SHA512 1e2b8e2ddb02b2009181a980781574e6e6375c98475bda4096b70a9c00e61c5ca445f28730e195a5179b85bf5464a6dcb1bcb6ba8dc841d95c9a111f8f87c511
-DIST trojan-1.9.0.tar.gz 37704 BLAKE2B 5ddfab3408c0f665e0c43e1f23d4d5df6c2222d38f3525b524b6689e5b25603f928f718bcba7bbd077b7db1c241aea629d01c8dbefc1d35c3dc3d29757c04885 SHA512 3d671d1944bf79879bde8ba74d9c3270e475ff1c5d35ff1ef367391fdce223bd24e4c1072ae8506002e5ee10944bfbe10cfb434e8908c9670535c38b275293fa
+DIST trojan-1.10.0.tar.gz 38230 BLAKE2B 2cfa77ebfbae62edef983d1e57e3ce00a61118f6458cab353af60960e2586750fcd0c4237631481cfdfc8ed0ddad586e1d649046269c7e9177594869c187d8d1 SHA512 9d9a74218369f8094b292b8892e5f877ccec7d8912657491bb37da8e9ae4817f07a83fe401e33bbbdd2ac9c50c1440f3a021f93d85999b43df4849b0a04049cf
similarity index 90%
rename from net-proxy/trojan/trojan-1.8.1.ebuild
rename to net-proxy/trojan/trojan-1.10.0.ebuild
index b6c8edf97d81fa1e9a43c358a1e744a840eab6a6..fb823826e18db14cb4884248270195dbeb0657ca 100644 (file)
@@ -5,7 +5,7 @@ EAPI=6
 
 PYTHON_COMPAT=( python{3_4,3_5,3_6,3_7} )
 
-inherit cmake-utils python-any-r1
+inherit cmake-utils python-any-r1 systemd
 
 DESCRIPTION="An unidentifiable mechanism that helps you bypass GFW"
 HOMEPAGE="https://github.com/trojan-gfw/${PN}"
@@ -31,6 +31,7 @@ src_configure() {
        local mycmakeargs=(
                -DENABLE_MYSQL=$(usex mysql)
                -DSYSTEMD_SERVICE=ON
+               -DSYSTEMD_SERVICE_PATH=$(systemd_get_systemunitdir)
                -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
        )
        cmake-utils_src_configure
diff --git a/net-proxy/trojan/trojan-1.9.0.ebuild b/net-proxy/trojan/trojan-1.9.0.ebuild
deleted file mode 100644 (file)
index b6c8edf..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{3_4,3_5,3_6,3_7} )
-
-inherit cmake-utils python-any-r1
-
-DESCRIPTION="An unidentifiable mechanism that helps you bypass GFW"
-HOMEPAGE="https://github.com/trojan-gfw/${PN}"
-SRC_URI="https://github.com/trojan-gfw/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="mysql test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-libs/boost-1.54.0:=
-       >=dev-libs/openssl-1.0.2:=
-       mysql? ( dev-db/mysql-connector-c:= )
-"
-DEPEND="
-       ${RDEPEND}
-       test? ( net-misc/curl ${PYTHON_DEPS} )
-"
-
-src_configure() {
-       local mycmakeargs=(
-               -DENABLE_MYSQL=$(usex mysql)
-               -DSYSTEMD_SERVICE=ON
-               -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
-       )
-       cmake-utils_src_configure
-}
-
-src_install() {
-       cmake-utils_src_install
-       newinitd "${FILESDIR}/trojan.initd" trojan
-}
-
-src_test() {
-       cmake-utils_src_test -j1
-}