dev-python/cheetah3-3.2.4: Version bump
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 29 Apr 2020 04:05:05 +0000 (21:05 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 29 Apr 2020 04:11:59 +0000 (21:11 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/cheetah3/Manifest
dev-python/cheetah3/cheetah3-3.2.4.ebuild [new file with mode: 0644]

index 7aca2361cfc917a45d09224d4668f05803f2801e..fd407552147179f65598a94946a62bbe73d4f083 100644 (file)
@@ -1 +1,2 @@
 DIST Cheetah3-3.2.3.tar.gz 875441 BLAKE2B 0fa4a533bd66f98e982312a451f464a2c3fb645916b98aaa92d3af219cb49e252985b4c675a612c1c9265f8028577be4be78b551ad4cdbbaca7f4439624193b9 SHA512 ebc735b59d61912679405469f9d509fc73bbdde51c414320994421849f4a02266d2c286c0f618cab2a592ab47ac0a4be9ec444fab75145a0c31dd0c3c39fc1e3
+DIST cheetah3-3.2.4.tar.gz 315044 BLAKE2B 5cb36364f424acf87593b3f18b5709d1a161dd3fb9bc1f4cfb6fe7c22d2515c852d5d7d0215692274ffe5437267e3232fcfae3d76c592cf66d8927fabdf37953 SHA512 64fbe95fe8d5f3185168ba780e106a46caa0656272235168df603eff50dd6e476eed041658a1e11ae12ee10d148a001c32a23677a1ee6da5b6d43e20e4d1e36e
diff --git a/dev-python/cheetah3/cheetah3-3.2.4.ebuild b/dev-python/cheetah3/cheetah3-3.2.4.ebuild
new file mode 100644 (file)
index 0000000..6e9a345
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="Python-powered template engine and code generator"
+HOMEPAGE="http://www.cheetahtemplate.org/ https://pypi.org/project/Cheetah3/"
+SRC_URI="https://github.com/CheetahTemplate3/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="
+       dev-python/markdown[${PYTHON_USEDEP}]
+       !dev-python/cheetah
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( ANNOUNCE.rst README.rst TODO )
+
+# Race in the test suite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+       # Disable broken tests.
+       sed \
+               -e "/Unicode/d" \
+               -e "s/if not sys.platform.startswith('java'):/if False:/" \
+               -e "/results =/a\\    sys.exit(not results.wasSuccessful())" \
+               -i Cheetah/Tests/Test.py || die "sed failed"
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       cp -r "${S}/Cheetah/Tests/ImportHooksTemplates" \
+               "${BUILD_DIR}/lib/Cheetah/Tests/ImportHooksTemplates" || die
+
+       "${PYTHON}" Cheetah/Tests/Test.py || die "Tests fail with ${EPYTHON}"
+}