Initial import. Fixes #46134.
authorKarl Trygve Kalleberg <karltk@gentoo.org>
Tue, 30 Mar 2004 23:59:47 +0000 (23:59 +0000)
committerKarl Trygve Kalleberg <karltk@gentoo.org>
Tue, 30 Mar 2004 23:59:47 +0000 (23:59 +0000)
dev-java/axion/ChangeLog [new file with mode: 0644]
dev-java/axion/axion-1.0_rc2.ebuild [new file with mode: 0644]
dev-java/axion/files/digest-axion-1.0_rc2 [new file with mode: 0644]
dev-java/axion/metadata.xml [new file with mode: 0644]

diff --git a/dev-java/axion/ChangeLog b/dev-java/axion/ChangeLog
new file mode 100644 (file)
index 0000000..46d4049
--- /dev/null
@@ -0,0 +1,6 @@
+# ChangeLog for dev-java/axion
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed unde the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/axion/ChangeLog,v 1.1 2004/03/30 23:59:47 karltk Exp $
+
+  01 Apr 2004; Karl Trygve Kalleberg <karltk@gentoo.org>
+  axion-1.0_rc2.ebuild: Initial import. Ebuild submitted by myself.
diff --git a/dev-java/axion/axion-1.0_rc2.ebuild b/dev-java/axion/axion-1.0_rc2.ebuild
new file mode 100644 (file)
index 0000000..47dc803
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/axion/axion-1.0_rc2.ebuild,v 1.1 2004/03/30 23:59:47 karltk Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Java RDMS with SQL and JDBC"
+HOMEPAGE="http://axion.tigris.org/"
+SRC_URI="http://axion.tigris.org/releases/1.0M2/axion-1.0-M2-src.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+RDEPEND=">=dev-java/commons-collections-2.1
+       =dev-java/commons-primitives-1.0*
+       =dev-java/commons-codec-1.2*
+       =dev-java/log4j-1.2*
+       =dev-java/regexp-1.3*
+       "
+DEPEND="${RDEPEND}
+       jikes? >=dev-java/jikes-1.19
+       junit? >=dev-java/junit-3.8.1
+       >=dev-java/ant-1.5.4"
+
+S=${WORKDIR}/${PN}-1.0-M2
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+       # It's pure luck that this works. Only the first element of
+       # each classpath will be picked. We need to symlink all
+       # jarfiles into lib/ at some point.
+       ( echo junit.jar=$(java-config -p junit)
+         echo collections.jar=$(java-config -p commons-collections)
+         echo primitives.jar=$(java-config -p commons-primitives)
+         echo logging.jar=$(java-config -p commons-logging)
+         echo codec.jar=$(java-config -p commons-codec)
+         echo logging-impl.jar=$(java-config -p log4j)
+         echo regexp.jar=$(java-config -p regexp)
+         echo javacc.home=/usr/share/javacc/lib
+       ) > build.properties
+
+       mkdir lib test
+       # Given the state of brokenness in this build system, we will
+       # need to do this for all the jars it depends on.
+       (
+               cd lib
+               for x in $(java-config -p commons-primitives | tr -d :) ; do
+                       ln -s ${x} .
+               done
+       )
+}
+
+src_compile() {
+       local antflags="compile jar"
+       use jikes && antflags="-Dbuild.compiler=jikes ${antflags}"
+       use doc && antflags="${antflags} javadoc"
+       use junit && antflags="${antflags} test"
+       ant ${antflags} || die "Compilation failed"
+}
+
+src_install() {
+       java-pkg_dojar bin/axion-1.0-M2.jar
+
+       use doc && dohtml -r bin/docs/api
+}
diff --git a/dev-java/axion/files/digest-axion-1.0_rc2 b/dev-java/axion/files/digest-axion-1.0_rc2
new file mode 100644 (file)
index 0000000..712e38e
--- /dev/null
@@ -0,0 +1 @@
+MD5 02de8320d148ddbe798c169e53240669 axion-1.0-M2-src.tar.gz 210568
diff --git a/dev-java/axion/metadata.xml b/dev-java/axion/metadata.xml
new file mode 100644 (file)
index 0000000..33a8442
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+Axion is a small, fast, open source relational database system (RDBMS)
+supporting SQL and JDBC written in and for the Java programming
+language.
+
+The Axion team is developing a complete, robust, modular, scalable and
+extensible relational database engine in Java under a
+commercial-friendly (BSD/Apache-style) license.
+</longdescription>
+</pkgmetadata>