app-admin/logrotate: simple safe sed line to fix bug 589854
authorZero_Chaos <zerochaos@gentoo.org>
Sat, 30 Jul 2016 13:36:46 +0000 (09:36 -0400)
committerZero_Chaos <zerochaos@gentoo.org>
Sat, 30 Jul 2016 13:37:10 +0000 (09:37 -0400)
Package-Manager: portage-2.3.0

app-admin/logrotate/logrotate-3.9.2-r1.ebuild

index 62b75e9e94d14b26aacd81c437358613a5ac13fd..60b8363956eb11b194f2ae00fbb747396c158553 100644 (file)
@@ -30,6 +30,7 @@ RDEPEND="${CDEPEND}
        cron? ( virtual/cron )"
 
 install_cron_file() {
+       sed -i 's#/usr/sbin/logrotate#/usr/bin/logrotate#' "${S}"/examples/logrotate.cron
        exeinto /etc/cron.daily
        newexe "${S}"/examples/logrotate.cron "${PN}"
 }