dev-java/icedtea: Patch CACAO for a dynamic maximum heap
authorJames Le Cuirot <chewi@gentoo.org>
Mon, 7 Sep 2015 22:42:34 +0000 (23:42 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Mon, 7 Sep 2015 22:43:42 +0000 (23:43 +0100)
It has been discovered that CACAO has been giving us memory problems
because it had a fixed default heap size of only 128MB, whereas
HotSpot uses a quarter of the physical RAM. I have patched CACAO to do
the same. See IcedTea bugs #2611 and #2612.

Package-Manager: portage-2.2.20.1

dev-java/icedtea/files/6-cacao-dynmaxheap-Makefile.patch [new file with mode: 0644]
dev-java/icedtea/files/6-cacao-dynmaxheap.patch [new file with mode: 0644]
dev-java/icedtea/files/7-cacao-dynmaxheap-Makefile.patch [new file with mode: 0644]
dev-java/icedtea/files/7-cacao-dynmaxheap.patch [new file with mode: 0644]
dev-java/icedtea/icedtea-6.1.13.8-r1.ebuild [moved from dev-java/icedtea/icedtea-6.1.13.8.ebuild with 97% similarity]
dev-java/icedtea/icedtea-7.2.5.6-r1.ebuild [moved from dev-java/icedtea/icedtea-7.2.5.6.ebuild with 98% similarity]

diff --git a/dev-java/icedtea/files/6-cacao-dynmaxheap-Makefile.patch b/dev-java/icedtea/files/6-cacao-dynmaxheap-Makefile.patch
new file mode 100644 (file)
index 0000000..dc87ae8
--- /dev/null
@@ -0,0 +1,10 @@
+--- Makefile.in.orig   2015-07-28 07:21:16.447388803 -0700
++++ Makefile.in        2015-09-06 09:13:16.548000000 -0700
+@@ -182,6 +182,7 @@
+ @WITH_RHINO_TRUE@     patches/rhino.patch
+ @BUILD_CACAO_TRUE@am__append_22 = \
++@BUILD_CACAO_TRUE@    patches/cacao/dynmaxheap.patch \
+ @BUILD_CACAO_TRUE@    patches/cacao/launcher.patch \
+ @BUILD_CACAO_TRUE@    patches/cacao/memory.patch \
+ @BUILD_CACAO_TRUE@    patches/cacao/hotspot/original/memory.patch \
diff --git a/dev-java/icedtea/files/6-cacao-dynmaxheap.patch b/dev-java/icedtea/files/6-cacao-dynmaxheap.patch
new file mode 100644 (file)
index 0000000..33b9818
--- /dev/null
@@ -0,0 +1,42 @@
+# HG changeset patch
+# User James Le Cuirot <chewi@gentoo.org>
+# Date 1441543564 -3600
+#      Sun Sep 06 13:46:04 2015 +0100
+# Node ID d0224f4490d6694e77dcb0ff7eae8e2297b822bf
+# Parent  e215e36be9fc2b7dfe43ff10ec1afe639b289aa5
+Dynamically set the maximum heap size on Linux
+
+diff -r e215e36be9fc -r d0224f4490d6 src/vm/vm.cpp
+--- cacao/cacao/src/vm/vm.cpp  Mon Feb 11 19:31:28 2013 +0100
++++ cacao/cacao/src/vm/vm.cpp  Sun Sep 06 13:46:04 2015 +0100
+@@ -33,6 +33,10 @@
+ #include <errno.h>
+ #include <stdlib.h>
++#if defined(__LINUX__)
++#include <unistd.h>
++#endif
++
+ #include "vm/types.h"
+ #include "arch.h"
+@@ -702,6 +706,19 @@
+       opt_heapstartsize = HEAP_STARTSIZE;
+       opt_stacksize     = STACK_SIZE;
++#if defined(__LINUX__)
++      // Calculate 1/4 of the physical memory.
++      uint64_t qmem = sysconf(_SC_PHYS_PAGES) * sysconf(_SC_PAGESIZE) / 4;
++
++      if (qmem > INT32_MAX) {
++              // More than 2GB will overflow so cap it.
++              opt_heapmaxsize = 2047 * 1024 * 1024;
++      } else if (qmem > HEAP_MAXSIZE) {
++              // Otherwise use this if greater than default (128MB).
++              opt_heapmaxsize = (s4) qmem;
++      }
++#endif
++
+       // First of all, parse the -XX options.
+ #if defined(ENABLE_VMLOG)
diff --git a/dev-java/icedtea/files/7-cacao-dynmaxheap-Makefile.patch b/dev-java/icedtea/files/7-cacao-dynmaxheap-Makefile.patch
new file mode 100644 (file)
index 0000000..13e3053
--- /dev/null
@@ -0,0 +1,10 @@
+--- Makefile.in.orig   2015-07-22 14:54:37.116940780 -0700
++++ Makefile.in        2015-09-06 05:05:47.220000000 -0700
+@@ -134,6 +134,7 @@
+ @WITH_RHINO_TRUE@     patches/rhino.patch
+ @BUILD_CACAO_TRUE@am__append_10 = \
++@BUILD_CACAO_TRUE@    patches/cacao/dynmaxheap.patch \
+ @BUILD_CACAO_TRUE@    patches/cacao/launcher.patch \
+ @BUILD_CACAO_TRUE@    patches/cacao/memory.patch \
+ @BUILD_CACAO_TRUE@    patches/cacao/armhf.patch \
diff --git a/dev-java/icedtea/files/7-cacao-dynmaxheap.patch b/dev-java/icedtea/files/7-cacao-dynmaxheap.patch
new file mode 100644 (file)
index 0000000..33b9818
--- /dev/null
@@ -0,0 +1,42 @@
+# HG changeset patch
+# User James Le Cuirot <chewi@gentoo.org>
+# Date 1441543564 -3600
+#      Sun Sep 06 13:46:04 2015 +0100
+# Node ID d0224f4490d6694e77dcb0ff7eae8e2297b822bf
+# Parent  e215e36be9fc2b7dfe43ff10ec1afe639b289aa5
+Dynamically set the maximum heap size on Linux
+
+diff -r e215e36be9fc -r d0224f4490d6 src/vm/vm.cpp
+--- cacao/cacao/src/vm/vm.cpp  Mon Feb 11 19:31:28 2013 +0100
++++ cacao/cacao/src/vm/vm.cpp  Sun Sep 06 13:46:04 2015 +0100
+@@ -33,6 +33,10 @@
+ #include <errno.h>
+ #include <stdlib.h>
++#if defined(__LINUX__)
++#include <unistd.h>
++#endif
++
+ #include "vm/types.h"
+ #include "arch.h"
+@@ -702,6 +706,19 @@
+       opt_heapstartsize = HEAP_STARTSIZE;
+       opt_stacksize     = STACK_SIZE;
++#if defined(__LINUX__)
++      // Calculate 1/4 of the physical memory.
++      uint64_t qmem = sysconf(_SC_PHYS_PAGES) * sysconf(_SC_PAGESIZE) / 4;
++
++      if (qmem > INT32_MAX) {
++              // More than 2GB will overflow so cap it.
++              opt_heapmaxsize = 2047 * 1024 * 1024;
++      } else if (qmem > HEAP_MAXSIZE) {
++              // Otherwise use this if greater than default (128MB).
++              opt_heapmaxsize = (s4) qmem;
++      }
++#endif
++
+       // First of all, parse the -XX options.
+ #if defined(ENABLE_VMLOG)
similarity index 97%
rename from dev-java/icedtea/icedtea-6.1.13.8.ebuild
rename to dev-java/icedtea/icedtea-6.1.13.8-r1.ebuild
index 745d54be40f6e0afed8a46b45e6703b218f2d250..ff53a1134fc161c9a8d5143ddcf40604f04a8fbb 100644 (file)
@@ -152,6 +152,10 @@ src_unpack() {
 }
 
 java_prepare() {
+       # CACAO has a fixed default max heap of 128MB. This sucks.
+       cp "${FILESDIR}"/${SLOT}-cacao-dynmaxheap.patch patches/cacao/dynmaxheap.patch || die
+       epatch "${FILESDIR}"/${SLOT}-cacao-dynmaxheap-Makefile.patch
+
        # For bootstrap builds as the sandbox control file might not yet exist.
        addpredict /proc/self/coredump_filter
 
similarity index 98%
rename from dev-java/icedtea/icedtea-7.2.5.6.ebuild
rename to dev-java/icedtea/icedtea-7.2.5.6-r1.ebuild
index 06dbc68ac67fe69d1fda41fe95dcf7cb264e1827..d8a172f95c058cfb671edec352a9c27a5ee350a6 100644 (file)
@@ -196,6 +196,10 @@ src_unpack() {
 }
 
 java_prepare() {
+       # CACAO has a fixed default max heap of 128MB. This sucks.
+       cp "${FILESDIR}"/${SLOT}-cacao-dynmaxheap.patch patches/cacao/dynmaxheap.patch || die
+       epatch "${FILESDIR}"/${SLOT}-cacao-dynmaxheap-Makefile.patch
+
        if ! use cups; then
                # CUPS is always needed at build time but you can at least make it dlopen.
                sed -i 's/SYSTEM_CUPS="true"/SYSTEM_CUPS="false"/g' Makefile.in || die